Permalink
Browse files

TELEPATHY_QT*_FOUND depends on Qt version

  • Loading branch information...
1 parent a686d1f commit 6954e942f8ad070ef2145f5b97f93c713e4f9f31 @xhochy xhochy committed Feb 26, 2014
Showing with 5 additions and 1 deletion.
  1. +5 −1 CMakeLists.txt
View
@@ -282,7 +282,11 @@ endif()
if( UNIX AND NOT APPLE )
macro_optional_find_package(TelepathyQt 0.9.3)
- macro_log_feature(TelepathyQt4_FOUND "Telepathy-Qt" "Telepathy-Qt is a Qt high-level binding for Telepathy, a D-Bus framework for unifying real time communication." FALSE "" "Telepathy-Qt is needed for sharing Jabber/GTalk accounts with Telepathy.\n")
+ if ( TOMAHAWK_QT5 )
+ macro_log_feature(TelepathyQt5_FOUND "Telepathy-Qt" "Telepathy-Qt is a Qt high-level binding for Telepathy, a D-Bus framework for unifying real time communication." FALSE "" "Telepathy-Qt is needed for sharing Jabber/GTalk accounts with Telepathy.\n")
+ else ( TOMAHAWK_QT5)
+ macro_log_feature(TelepathyQt4_FOUND "Telepathy-Qt" "Telepathy-Qt is a Qt high-level binding for Telepathy, a D-Bus framework for unifying real time communication." FALSE "" "Telepathy-Qt is needed for sharing Jabber/GTalk accounts with Telepathy.\n")
+ endif()
endif()
# we need pthreads too

0 comments on commit 6954e94

Please sign in to comment.