Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Quick help is not updated #288

Open
maziac opened this Issue Dec 19, 2012 · 4 comments

Comments

Projects
None yet
3 participants

maziac commented Dec 19, 2012

The quick help (the window that appears on ALT-single click) seems to be updated only on the first appledoc run.
On subsequent appledoc runs the contents stays the same even if the comment of
the corresponding method has been altered (and saved).

E.g. do the following:

  1. run appledoc on the appledoc sources e.g.: appledoc -p x -c x -o helpdir .
  2. Goto GBGenerator.h
  3. ALT-single click on generateOutputFromStore:
  4. The quick help window appears with text "Generates all required ..."
  5. Change the comment to e.g. "UPDATED. all required ..."
  6. run appledoc again
  7. ALT-single click on generateOutputFromStore:
  8. The quick help window appears and still shows "Generates all required ..."

Strange is that if I go to the Organizer and look there the docset is correct, i.e.
it reads "UPDATED. all required ..." there.

Owner

tomaz commented Dec 19, 2012

AppleScript that updates Xcode no longer works with Xcode 4, so this may be the issues... Does it work if you restart Xcode?

maziac commented Dec 19, 2012

Hi,

no it does not work if I restart Xcode. But if I delete the docset (in Xcode) and then build it again.

BR,
Thomas

Am 19.12.2012 um 17:56 schrieb tomaz notifications@github.com:

AppleScript that updates Xcode no longer works with Xcode 4, so this may be the issues... Does it work if you restart Xcode?


Reply to this email directly or view it on GitHub.

Owner

tomaz commented Dec 20, 2012

If the docset gets updated, then there's either a bug in Xcode that doesn't update quick help, or there's some other mechanism that should be used to tell Xcode to update it (like publish it to website and subscribe to feed). I checked this in docset guide a while ago, but didn't find anything. I think it was this issue that I also filed a bug to Apple, but I didn't find a solution either. You may want to file a bug too - the more people ask for it, the better chance we'll get a fix :)

Collaborator

robvdveer commented Jul 23, 2013

I've just joined the project, and with Xcode 4.6.3 i found that you need to restart XCode to get the quickhelp changes visible. The changes are in the docset, so i doubt it is an appledoc error.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment