Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

connect_subproc bug #13

Closed
tomerfiliba opened this issue Mar 2, 2011 · 1 comment
Closed

connect_subproc bug #13

tomerfiliba opened this issue Mar 2, 2011 · 1 comment
Labels

Comments

@tomerfiliba
Copy link
Collaborator

@tomerfiliba tomerfiliba commented Mar 2, 2011

Aviv Ben-Yosef Show activity 11/11/09
Hello,

I've been trying to use the rpyc.classic.connect_subproc function, and
found out that it passes Popen the string 'python' as the executable.
The problem is that on machines where 'python' is not the name of the
python executable, or isn't the executable that was used to execute
the code in the first place, it won't work.

This should be changed to sys.executable instead (I can send in the
patch if needed).

@tomerfiliba
Copy link
Collaborator Author

@tomerfiliba tomerfiliba commented Mar 2, 2011

fixes a28b882; closed by 7eb48a4; closed by 7eb48a4; closed by 7eb48a4; closed by 7eb48a4; closed by 7eb48a4; closed by 7eb48a4;

This issue was closed.
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Labels
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
1 participant