New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Invalid syntax for Python 2.5 using from easy_install rpyc #143

Closed
nomel opened this Issue Oct 4, 2014 · 0 comments

Comments

Projects
None yet
1 participant
@nomel

nomel commented Oct 4, 2014

Using installation method of "easy_install.exe rpyc"
Trying to execute "rpyc_classic.py --help", as described in the tutorial, gives:

Traceback (most recent call last):
File "rpyc_classic.py", line 5, in
pkg_resources.run_script('rpyc==3.3.0', 'rpyc_classic.py')
File "c:\python25\lib\site-packages\pkg_resources.py", line 448, in run_script
self.require(requires)[0].run_script(script_name, ns)
File "c:\python25\lib\site-packages\pkg_resources.py", line 1166, in run_script
execfile(script_filename, namespace, namespace)
File "c:\python25\lib\site-packages\rpyc-3.3.0-py2.5-win32.egg\EGG-INFO\scripts\rpyc_classic.py", line 13, in
import rpyc
File "c:\python25\lib\site-packages\rpyc-3.3.0-py2.5-win32.egg\rpyc__init__.py", line 44, in
from rpyc.core import (SocketStream, TunneledSocketStream, PipeStream, Channel,
File "c:\python25\lib\site-packages\rpyc-3.3.0-py2.5-win32.egg\rpyc\core__init__.py", line 1, in
from rpyc.core.stream import SocketStream, TunneledSocketStream, PipeStream
File "c:\python25\lib\site-packages\rpyc-3.3.0-py2.5-win32.egg\rpyc\core\stream.py", line 42
except select_error as ex:
^
SyntaxError: invalid syntax

As doesn't exist in Python 2.5. No love for obsolete versions. :(

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment