I don't install chili_videos plagin #15

Open
Maxim-B opened this Issue Dec 16, 2011 · 7 comments

Projects

None yet

2 participants

@Maxim-B
Maxim-B commented Dec 16, 2011

Hi. I have broblem with instal this plugin.
When i put command 'gem install chili_videos' i give message "ERROR: While executing gem ... (NoMethodError)
undefined method `call' for nil:NilClass".

Thanks,
Maxim.

@tomkersten
Owner

Thanks for the bug report. Can you let me know the following information:

  1. What version of Redmine/ChiliProject are you using?
  2. What version of Ruby are you using (ruby -v)?
  3. What is the output of gem install chili_videos --trace?
@Maxim-B
Maxim-B commented Dec 19, 2011
  1. version of Redmine 1.2.1
  2. vercion Ruby 1.8.7
  3. Output of gem install chili_videos --trace:
    ERROR: While executing gem ... (OptionParser::InvalidOption)
    invalid option: --trace

Thanks for help.

@tomkersten
Owner

Sorry that was the wrong command to have you run, I read it too quick and assumed the error was on the rake command.

  1. What version of Rubygems are you using (ie: gem --version)?
  2. What is the output of gem install --backtrace chili_videos
@Maxim-B
Maxim-B commented Dec 20, 2011
  1. version of Rubygems 1.4.0
  2. Output:
    ERROR: While executing gem ... (NoMethodError)
    undefined method call' for nil:NilClass /usr/local/lib/ruby/site_ruby/1.8/rubygems/requirement.rb:134:insatisfied_by?'
    /usr/local/lib/ruby/1.8/fileutils.rb:243:in all?' /usr/local/lib/ruby/site_ruby/1.8/rubygems/requirement.rb:134:ineach'
    /usr/local/lib/ruby/site_ruby/1.8/rubygems/requirement.rb:134:in all?' /usr/local/lib/ruby/site_ruby/1.8/rubygems/requirement.rb:134:insatisfied_by?'
    /usr/local/lib/ruby/site_ruby/1.8/rubygems/source_index.rb:293:in search' /usr/local/lib/ruby/site_ruby/1.8/rubygems/source_index.rb:291:inselect'
    /usr/local/lib/ruby/site_ruby/1.8/rubygems/source_index.rb:291:in search' /usr/local/lib/ruby/site_ruby/1.8/rubygems/source_index.rb:248:infind_name'
    /usr/local/lib/ruby/site_ruby/1.8/rubygems/installer.rb:243:in installation_satisfies_dependency?' /usr/local/lib/ruby/site_ruby/1.8/rubygems/installer.rb:232:inensure_dependency'
    /usr/local/lib/ruby/site_ruby/1.8/rubygems/installer.rb:181:in install' /usr/local/lib/ruby/site_ruby/1.8/rubygems/installer.rb:180:ineach'
    /usr/local/lib/ruby/site_ruby/1.8/rubygems/installer.rb:180:in install' /usr/local/lib/ruby/site_ruby/1.8/rubygems/dependency_installer.rb:284:ininstall'
    /usr/local/lib/ruby/site_ruby/1.8/rubygems/dependency_installer.rb:254:in each' /usr/local/lib/ruby/site_ruby/1.8/rubygems/dependency_installer.rb:254:ininstall'
    /usr/local/lib/ruby/site_ruby/1.8/rubygems/commands/install_command.rb:120:in execute' /usr/local/lib/ruby/site_ruby/1.8/rubygems/commands/install_command.rb:115:ineach'
    /usr/local/lib/ruby/site_ruby/1.8/rubygems/commands/install_command.rb:115:in execute' /usr/local/lib/ruby/site_ruby/1.8/rubygems/command.rb:278:ininvoke'
    /usr/local/lib/ruby/site_ruby/1.8/rubygems/command_manager.rb:134:in process_args' /usr/local/lib/ruby/site_ruby/1.8/rubygems/command_manager.rb:104:inrun'
    /usr/local/lib/ruby/site_ruby/1.8/rubygems/gem_runner.rb:63:in `run'
    /usr/local/bin/gem:21

Thanks for help.

@tomkersten
Owner

Hmmm...that's a pretty old version of Rubygems. I'll see if I can get it installed and reproduce the issue on my end.

Is it possible for you to upgrade your version of Rubygems? If so and you can try that on your end, that may resolve it as well.

As I said, I'll see if I can track it down on my end as well. I don't know what all the changes in Rubygems have been since v1.4, but that is the thing that catches my eye the most so far...

Let me know if you are able to upgrade on your end and I will let you know if I can reproduce it on mine. ;-)

@Maxim-B
Maxim-B commented Dec 23, 2011

Hi, Tom.
I can't upgrate Rubygems, because redmine don't work with RubyGems 1.7.0 or later. But I installed chili_videos version 0.1.0 successful. It's works.
But on the setup page of this plugin I must enter a Transload.it API key and Workflow parameters. What are these parameters?

@tomkersten
Owner

Sorry for the delayed response on this...

Transload.it is a service is a transcoding service...which this plugin completely relies on at this point. It takes a raw file...say a .mov file and transcodes it however you see fit and then stores it wherever you specify. This plugin feeds off of this service to convert (transcode) movie files. The parameters it is looking for are the params needed to display the form to perform the upload to the Transload.it service.

Does that make sense?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment