Skip to content
Permalink
Browse files

Merge pull request gnosis#60 from gnosis/BUG/DEV-72-ethlightwallet-no…

…t-found

Solved ethlightwallet issue on electron, moved ethlightwallet lib to …
  • Loading branch information...
giacomolicari committed Jan 26, 2018
2 parents 8cc899b + 28d0240 commit d54674536ad68c4f2a2990f622cbd76b86401d40
Showing with 6 additions and 4 deletions.
  1. +0 −1 dapp/bower.json
  2. +1 −1 dapp/index.html
  3. +3 −1 dapp/main.js
  4. +2 −1 dapp/package.json
@@ -41,7 +41,6 @@
"abi-decoder": "1.0.8",
"SpinKit": "spinkit#^1.2.5",
"web3-provider-engine": "https://github.com/denisgranha/provider-engine.git#dce3f8d701eb1fcd794c86f2debb6af752aa44b3",
"eth-lightwallet": "https://github.com/ConsenSys/eth-lightwallet.git",
"file-saver": "^1.3.3",
"hooked-web3-provider": "https://github.com/ConsenSys/hooked-web3-provider.git",
"entropy-collector": "https://github.com/vibornoff/entropy-collector.js.git",
@@ -47,7 +47,7 @@
<script src="./bower_components/angular-ui-notification/dist/angular-ui-notification.min.js"></script>
<script>
if (isElectron) {
var lightwallet = require("./bower_components/eth-lightwallet/dist/lightwallet.min.js");
var lightwallet = require("eth-lightwallet");
var FileSaver = require("./bower_components/file-saver/FileSaver.min.js");
var ethereumWallet = require('ethereumjs-wallet');
var HookedWalletProvider = require('./bower_components/web3-provider-engine/subproviders/hooked-wallet');
@@ -200,7 +200,9 @@ function createWindow () {
}));

// Open the DevTools.
mainWindow.webContents.openDevTools();
if (process.env.NODE_ENV == 'development') {
mainWindow.webContents.openDevTools();
}

// Declare context menus
const selectionMenu = Menu.buildFromTemplate([
@@ -18,7 +18,7 @@
"install-electron": "npm install && ./node_modules/.bin/electron-rebuild",
"electron-rebuild": "electron-rebuild --force --module_dir . -w node-hid -e node_modules/electron && npm rebuild leveldown scrypt",
"start": "http-server -a 0.0.0.0 -p 5000",
"start-electron": "electron .",
"start-electron": "NODE_ENV=development electron .",
"package-linux-x64": "electron-packager . MultisigWallet --prune --ignore=tests/* --ignore=testrpc.sh --platform=linux --out=./dist --overwrite=true --asar=true",
"package-osx": "electron-packager . MultisigWallet --prune --ignore=tests/* --ignore=testrpc.sh --platform=darwin --out=./dist --overwrite=true --asar=true",
"package-win": "electron-packager . MultisigWallet --prune --ignore=tests/* --ignore=testrpc.sh --platform=win32 --out=./dist --overwrite=true --asar=true",
@@ -59,6 +59,7 @@
"eth-sig-util": "^1.2.1",
"ethereumjs-testrpc": "git+https://github.com/denisgranha/testrpc.git",
"ethereumjs-wallet": "^0.6.0",
"eth-lightwallet": "^3.0.1",
"express": "^4.15.2",
"grunt": "^1.0.0",
"grunt-angular-templates": "^1.1.0",

0 comments on commit d546745

Please sign in to comment.
You can’t perform that action at this time.