Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Project build is utterly broken #4

Closed
dlandis opened this Issue May 28, 2012 · 2 comments

Comments

Projects
None yet
2 participants

dlandis commented May 28, 2012

Attempting to build according to the instructions in the README:

% mvn package -DskipTests -Dhadoop.version=1.0.1

results in:

[ERROR] COMPILATION ERROR : [INFO] ------------------------------------------------------------- [ERROR] /home/dlandis/git/hadoop-book/common/src/main/java/oldapi/MetOfficeRecordParser.java:[4,27] error: package org.apache.hadoop.io does not exist

There also seems to be other issues with the maven configuration as evidenced by the Issues list. This is frustrating since I actually just bought the book (not cheap) only to find the code is a mess.

Owner

tomwhite commented May 28, 2012

Please try

% mvn package -DskipTests -Dhadoop.version=1.0.2

I forgot to change the version number in the README when I updated the code to use Hadoop 1.0.2. I've just fixed the README now.

Thanks,
Tom

Owner

tomwhite commented Jan 10, 2014

Closing this since it's two years old now. BTW the build can build against different versions of Hadoop now since #14 was committed.

@tomwhite tomwhite closed this Jan 10, 2014

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment