Tmux version checking fails under Arch Linux #55

Closed
iynaix opened this Issue Feb 25, 2014 · 2 comments

Comments

2 participants

iynaix commented Feb 25, 2014

The version checking for tmux fails under Arch Linux, which reports the version as '1.9a'. The tmux version was updated to 1.9a on 24 Feb 2014. (https://www.archlinux.org/packages/community/x86_64/tmux/)

Traceback (most recent call last):
  File "/usr/sbin/tmuxp", line 9, in <module>
    load_entry_point('tmuxp==0.1.6', 'console_scripts', 'tmuxp')()
  File "/usr/lib/python3.3/site-packages/tmuxp/cli.py", line 946, in main
    util.has_required_tmux_version()
  File "/usr/lib/python3.3/site-packages/tmuxp/util.py", line 275, in has_required_tmux_version
    if StrictVersion(version) <= StrictVersion("1.7"):
  File "/usr/lib/python3.3/distutils/version.py", line 40, in __init__
    self.parse(vstring)
  File "/usr/lib/python3.3/distutils/version.py", line 143, in parse
    raise ValueError("invalid version number '%s'" % vstring)
ValueError: invalid version number '1.9a'

tony closed this in 87293f6 Feb 25, 2014

Owner

tony commented Feb 25, 2014

@iynaix How is v0.1.7?

iynaix commented Feb 25, 2014

Works for me. Thanks!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment