Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

assets:precompile fails without error #5696

Closed
almafeta opened this issue Nov 14, 2017 · 3 comments

Comments

@almafeta
Copy link

commented Nov 14, 2017

When attempting to run RAILS_ENV=production bundle exec rails assets:precompile as per https://github.com/tootsuite/documentation/blob/master/Running-Mastodon/Production-guide.md, compilation fails without any error code:

Webpacker is installed 
Using /home/mastodon/live/config/webpacker.yml file for setting up webpack paths
Compiling…
Compilation failed:


There are multiple newlines, but no explanation as to why compilation failed, so it does not look like an OOM error or permissions error at first glance.


  • [+] I searched or browsed the repo’s other issues to ensure this is not a duplicate.
  • [+] This bug happens on a tagged release and not on master (If you're a user, don't worry about this). 09d81de (v2.0.0)
@almafeta

This comment has been minimized.

Copy link
Author

commented Nov 16, 2017

After about the fifth run without any changes, it finally did return an error - an out-of-memory error. So this issue is not with the software, and I'm closing this issue.

Future Googlers: 1GB of memory is not enough to precompile assets!

@almafeta almafeta closed this Nov 16, 2017

@jgroszko

This comment has been minimized.

Copy link

commented Aug 21, 2018

Does anyone have any tips on how to precompile the assets on another machine, and then move them out to my server?

@oufmilo

This comment has been minimized.

Copy link

commented Jun 20, 2019

I have the same problem when i run assets:precompile, i never have this before...
Someone have an idea ?
Thanks

yarn install v1.16.0
[1/6] Validating package.json...
[2/6] Resolving packages...
[3/6] Fetching packages...
info fsevents@1.2.9: The platform "linux" is incompatible with this module.
info "fsevents@1.2.9" is an optional dependency and failed compatibility check. Excluding it from installation.
[4/6] Linking dependencies...
[5/6] Building fresh packages...
[6/6] Cleaning modules...
Done in 22.85s.
Compiling…
Compilation failed:
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
3 participants
You can’t perform that action at this time.