Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Bump capybara from 3.18.0 to 3.19.1 #10758

Merged
merged 1 commit into from May 14, 2019

Conversation

Projects
None yet
2 participants
@dependabot
Copy link
Contributor

commented May 13, 2019

Bumps capybara from 3.18.0 to 3.19.1.

Changelog

Sourced from capybara's changelog.

Version 3.19.1

Release date: 2019-05-11

Fixed

  • Fix access to specializations when Selenium::Driver is subclassed [James Mead]

Version 3.19.0

Release date: 2019-05-09

Added

  • Syntactic sugar #once, #twice, #thrice, #exactly, #at_least, #at_most, and #times
    added to have_selector, have_css, have_xpath, and have_text RSpec matchers
  • Support for multiple expression types in Selector definitions
  • Reduced wirecalls for common actions in Selenium driver

Fixed

  • Workaround Chrome 75 appending files to multiple file inputs
  • Suppressed retry when detecting http vs https server connection
Commits
  • 7cbdca6 Prepare for 3.19.1 release
  • 1bd9124 Fix access to specializations when Selenium::Driver is subclassed
  • 158b104 Description was wrong
  • fce6a8d Update README.md for 3.19 release branch [ci skip]
  • 818ee53 Prepare for 3.19.0 release
  • 1419fad Remove obsolete legacy drivers from the README
  • 8a41f47 Merge pull request #2183 from artur-beljajev/update-readme
  • e0ec0d0 Update rubocop config
  • 8ec78ab Add syntatic sugar to have_selector and have_text matchers
  • 40b51e2 No need to catch error classes whose base classes are already specified
  • Additional commits viewable in compare view

Dependabot compatibility score

Dependabot will resolve any conflicts with this PR as long as you don't alter it yourself. You can also trigger a rebase manually by commenting @dependabot rebase.


Dependabot commands and options

You can trigger Dependabot actions by commenting on this PR:

  • @dependabot rebase will rebase this PR
  • @dependabot recreate will recreate this PR, overwriting any edits that have been made to it
  • @dependabot merge will merge this PR after your CI passes on it
  • @dependabot squash and merge will squash and merge this PR after your CI passes on it
  • @dependabot cancel merge will cancel a previously requested merge and block automerging
  • @dependabot reopen will reopen this PR if it is closed
  • @dependabot ignore this [patch|minor|major] version will close this PR and stop Dependabot creating any more for this minor/major version (unless you reopen the PR or upgrade to it yourself)
  • @dependabot ignore this dependency will close this PR and stop Dependabot creating any more for this dependency (unless you reopen the PR or upgrade to it yourself)
  • @dependabot use these labels will set the current labels as the default for future PRs for this repo and language
  • @dependabot use these reviewers will set the current reviewers as the default for future PRs for this repo and language
  • @dependabot use these assignees will set the current assignees as the default for future PRs for this repo and language
  • @dependabot use this milestone will set the current milestone as the default for future PRs for this repo and language
  • @dependabot badge me will comment on this PR with code to add a "Dependabot enabled" badge to your readme

Additionally, you can set the following in your Dependabot dashboard:

  • Update frequency (including time of day and day of week)
  • Automerge options (never/patch/minor, and dev/runtime dependencies)
  • Pull request limits (per update run and/or open at any time)
  • Out-of-range updates (receive only lockfile updates, if desired)
  • Security updates (receive only security updates, if desired)

Finally, you can contact us by mentioning @dependabot.

Bump capybara from 3.18.0 to 3.19.1
Bumps [capybara](https://github.com/teamcapybara/capybara) from 3.18.0 to 3.19.1.
- [Release notes](https://github.com/teamcapybara/capybara/releases)
- [Changelog](https://github.com/teamcapybara/capybara/blob/master/History.md)
- [Commits](teamcapybara/capybara@3.18.0...3.19.1)

Signed-off-by: dependabot[bot] <support@dependabot.com>
@ykzts

ykzts approved these changes May 14, 2019

@ykzts ykzts merged commit 76901b6 into master May 14, 2019

11 checks passed

ci/circleci: build Your tests passed on CircleCI!
Details
ci/circleci: check-i18n Your tests passed on CircleCI!
Details
ci/circleci: install Your tests passed on CircleCI!
Details
ci/circleci: install-ruby2.4 Your tests passed on CircleCI!
Details
ci/circleci: install-ruby2.5 Your tests passed on CircleCI!
Details
ci/circleci: install-ruby2.6 Your tests passed on CircleCI!
Details
ci/circleci: test-ruby2.4 Your tests passed on CircleCI!
Details
ci/circleci: test-ruby2.5 Your tests passed on CircleCI!
Details
ci/circleci: test-ruby2.6 Your tests passed on CircleCI!
Details
ci/circleci: test-webui Your tests passed on CircleCI!
Details
codeclimate All good!
Details

@ykzts ykzts deleted the dependabot/bundler/capybara-3.19.1 branch May 14, 2019

noellabo added a commit to fedibird/mastodon that referenced this pull request May 19, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.