New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Update dependencies for Node.js (2018-12-31) #9669

Merged
merged 37 commits into from Dec 31, 2018

Conversation

Projects
None yet
2 participants
@ykzts
Copy link
Collaborator

ykzts commented Dec 30, 2018

No description provided.

@ykzts ykzts removed the work in progress label Dec 31, 2018

"yargs": "^8.0.2"
},
"optionalDependencies": {
"fsevents": "*",
"node-zopfli": "^2.0.2"

This comment has been minimized.

@ykzts

ykzts Dec 31, 2018

Collaborator

Replace to @gfx/zopfli.

node-zopfli has not been maintained for a long-term.

"webpack": "^4.18.0",
"webpack-bundle-analyzer": "^2.13.1",
"webpack-cli": "^3.0.8",
"webpack-manifest-plugin": "^2.0.4",

This comment has been minimized.

@ykzts

ykzts Dec 31, 2018

Collaborator

Replace to webpack-assets-manifest.

webpack-manifest-plugin has not been maintained for a long-term.

"path-complete-extname": "^1.0.0",
"pg": "^6.4.0",
"postcss-loader": "^3.0.0",
"postcss-object-fit-images": "^1.1.2",
"postcss-smart-import": "^0.7.6",
"precss": "^3.1.2",

This comment has been minimized.

@ykzts

ykzts Dec 31, 2018

Collaborator

precss does the same processing as sass-loader.

"path-complete-extname": "^1.0.0",
"pg": "^6.4.0",
"postcss-loader": "^3.0.0",
"postcss-object-fit-images": "^1.1.2",
"postcss-smart-import": "^0.7.6",

This comment has been minimized.

@ykzts

ykzts Dec 31, 2018

Collaborator

postcss-smart-import does the same processing as sass-loader.

"mkdirp": "^0.5.1",
"node-sass": "^4.9.2",

This comment has been minimized.

@ykzts

ykzts Dec 31, 2018

Collaborator

Replace to sass.

Because node-sass depends on C ++, it takes time to install the package. Since sass is provided with pure JavaScript, it can be installed immediately.

return link;
};

export default Link;

This comment has been minimized.

@ykzts

ykzts Dec 31, 2018

Collaborator

This monkey-patch is no longer needed.

https://github.com/jhermsmeier/node-http-link-header/12

@Gargron Gargron merged commit 8f5fdab into tootsuite:master Dec 31, 2018

11 checks passed

ci/circleci: build Your tests passed on CircleCI!
Details
ci/circleci: check-i18n Your tests passed on CircleCI!
Details
ci/circleci: install Your tests passed on CircleCI!
Details
ci/circleci: install-ruby2.4 Your tests passed on CircleCI!
Details
ci/circleci: install-ruby2.5 Your tests passed on CircleCI!
Details
ci/circleci: install-ruby2.6 Your tests passed on CircleCI!
Details
ci/circleci: test-ruby2.4 Your tests passed on CircleCI!
Details
ci/circleci: test-ruby2.5 Your tests passed on CircleCI!
Details
ci/circleci: test-ruby2.6 Your tests passed on CircleCI!
Details
ci/circleci: test-webui Your tests passed on CircleCI!
Details
codeclimate All good!
Details

@ykzts ykzts deleted the ykzts:yarn-upgrade-20181230 branch Dec 31, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment