Skip to content
Browse files

Adding missing gem dependencies - mime-types and thor

  • Loading branch information...
1 parent bff6d82 commit 3c67929f74382094152a1b42953d8eb9d1b3fa15 @rubbish rubbish committed with quirkey Oct 2, 2010
Showing with 9 additions and 1 deletion.
  1. +2 −0 Rakefile
  2. +7 −1 soca.gemspec
View
2 Rakefile
@@ -12,7 +12,9 @@ begin
gem.homepage = "http://github.com/quirkey/soca"
gem.authors = ["Aaron Quint"]
gem.add_dependency 'json', '~>1.4.6'
+ gem.add_dependency 'mime-types', '~>1.16'
gem.add_dependency 'typhoeus', '~>0.1.31'
+ gem.add_dependency 'thor', '~>0.14.0'
gem.add_dependency 'jim', '~>0.2.3'
gem.add_dependency 'compass', '~>0.10.5'
gem.add_development_dependency "shoulda", ">= 0"
View
8 soca.gemspec
@@ -9,7 +9,7 @@ Gem::Specification.new do |s|
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Aaron Quint"]
- s.date = %q{2010-09-26}
+ s.date = %q{2010-10-02}
s.default_executable = %q{soca}
s.description = %q{soca is a different way of writing apps for CouchDB. The structure is up to you.}
s.email = %q{aaron@quirkey.com}
@@ -82,22 +82,28 @@ Gem::Specification.new do |s|
if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
s.add_runtime_dependency(%q<json>, ["~> 1.4.6"])
+ s.add_runtime_dependency(%q<mime-types>, ["~> 1.16"])
s.add_runtime_dependency(%q<typhoeus>, ["~> 0.1.31"])
+ s.add_runtime_dependency(%q<thor>, ["~> 0.14.0"])
s.add_runtime_dependency(%q<jim>, ["~> 0.2.3"])
s.add_runtime_dependency(%q<compass>, ["~> 0.10.5"])
s.add_development_dependency(%q<shoulda>, [">= 0"])
s.add_development_dependency(%q<yard>, [">= 0"])
else
s.add_dependency(%q<json>, ["~> 1.4.6"])
+ s.add_dependency(%q<mime-types>, ["~> 1.16"])
s.add_dependency(%q<typhoeus>, ["~> 0.1.31"])
+ s.add_dependency(%q<thor>, ["~> 0.14.0"])
s.add_dependency(%q<jim>, ["~> 0.2.3"])
s.add_dependency(%q<compass>, ["~> 0.10.5"])
s.add_dependency(%q<shoulda>, [">= 0"])
s.add_dependency(%q<yard>, [">= 0"])
end
else
s.add_dependency(%q<json>, ["~> 1.4.6"])
+ s.add_dependency(%q<mime-types>, ["~> 1.16"])
s.add_dependency(%q<typhoeus>, ["~> 0.1.31"])
+ s.add_dependency(%q<thor>, ["~> 0.14.0"])
s.add_dependency(%q<jim>, ["~> 0.2.3"])
s.add_dependency(%q<compass>, ["~> 0.10.5"])
s.add_dependency(%q<shoulda>, [">= 0"])

0 comments on commit 3c67929

Please sign in to comment.
Something went wrong with that request. Please try again.