Torch install on Fedora 22 - patch for install-deps #62

Closed
aspratyush opened this Issue Jun 23, 2015 · 1 comment

Comments

Projects
None yet
2 participants
@aspratyush
Contributor

aspratyush commented Jun 23, 2015

  • Existing install-deps script supports Fedora 20
  • Following is the patch that makes the script compatible with Fedora 22:
177,184c177,183
<         if [[ $fedora_major_version == '20' ]]; then
<             sudo yum install -y cmake curl readline-devel ncurses-devel \
<                                 gcc-c++ gcc-gfortran git gnuplot unzip \
<                                 nodejs npm libjpeg-turbo-devel libpng-devel \
<                                 ImageMagick GraphicsMagick-devel fftw-devel \
<                                 sox-devel sox zeromq3-devel \
<                                 qt-devel qtwebkit-devel sox-plugins-freeworld \
<                                 ipython

---
>         if [[ $fedora_major_version == '22' ]]; then
>             sudo dnf install -y cmake curl readline-devel ncurses-devel \
>                       gcc-c++ gcc-gfortran git gnuplot unzip \
>                       nodejs npm libjpeg-turbo-devel libpng-devel \
>                       ImageMagick GraphicsMagick-devel fftw-devel \
>                       sox-devel sox qt-devel qtwebkit-devel \
>                       python-ipython czmq czmq-devel
222a222
> 
@mcsaucy

This comment has been minimized.

Show comment
Hide comment
@mcsaucy

mcsaucy Jun 23, 2015

Contributor

Can you make a pull request with these changes?

Contributor

mcsaucy commented Jun 23, 2015

Can you make a pull request with these changes?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment