Permalink
Browse files

Add futures to travis and vm tests, update assorted dependency versions.

  • Loading branch information...
1 parent 6e40f50 commit 3747af59cb82bdfa71b2c0041fc0d6fc4d8df2b4 @bdarnell bdarnell committed Sep 30, 2012
View
6 .travis.yml
@@ -21,10 +21,10 @@ matrix:
install:
- if [[ $TRAVIS_PYTHON_VERSION == '2.5' ]]; then pip install --use-mirrors simplejson unittest2; fi
- if [[ $TRAVIS_PYTHON_VERSION == '2.6' ]]; then pip install --use-mirrors unittest2; fi
- - if [[ $FULL == 'true' ]]; then sudo apt-get install librtmp-dev; pip install --use-mirrors pycurl; fi
+ - if [[ $FULL == 'true' ]]; then sudo apt-get install librtmp-dev; pip install --use-mirrors pycurl futures; fi
- if [[ $FULL == 'true' && $TRAVIS_PYTHON_VERSION == '2.5' ]]; then pip install --use-mirrors twisted==11.0.0 'zope.interface<4.0'; fi
- - if [[ $FULL == 'true' && $TRAVIS_PYTHON_VERSION == '2.6' ]]; then pip install --use-mirrors twisted==11.0.0; fi
- - if [[ $FULL == 'true' && $TRAVIS_PYTHON_VERSION == '2.7' ]]; then pip install --use-mirrors twisted==12.0.0; fi
+ - if [[ $FULL == 'true' && $TRAVIS_PYTHON_VERSION == '2.6' ]]; then pip install --use-mirrors twisted==12.0.0; fi
+ - if [[ $FULL == 'true' && $TRAVIS_PYTHON_VERSION == '2.7' ]]; then pip install --use-mirrors twisted==12.2.0; fi
- python setup.py install
script:
# Must cd somewhere else so python3 doesn't get confused and run
View
11 maint/requirements.txt
@@ -1,17 +1,18 @@
# Frozen pip requirements for tools used in the development of tornado
# Tornado's optional dependencies
-Twisted==12.1.0
+Twisted==12.2.0
+futures==2.1.3
pycurl==7.19.0
# Other useful tools
Sphinx==1.1.3
-autopep8==0.6.5
+autopep8==0.8.1
coverage==3.5.2
-pep8==1.2
+pep8==1.3.3
pyflakes==0.5.0
-tox==1.4
-virtualenv==1.7.1.2
+tox==1.4.2
+virtualenv==1.8.2
# Indirect dependencies
Jinja2==2.6
View
3 maint/vm/freebsd/setup.sh
@@ -14,8 +14,9 @@ ftp/curl
"
PIP_PACKAGES="
-tox
+futures
pycurl
+tox
"
cd /usr/ports
View
3 maint/vm/freebsd/tox.ini
@@ -8,6 +8,7 @@ toxworkdir=/usr/home/vagrant/tox-tornado
commands = python -m tornado.test.runtests {posargs:}
[testenv:py27-full]
-# other dependencies aren't really worth the install time
+# twisted's tests fail on freebsd
deps =
+ futures
pycurl
View
5 maint/vm/ubuntu10.04/setup.sh
@@ -37,10 +37,11 @@ apt-get -y install $DEADSNAKES_PACKAGES
PIP_PACKAGES="
-virtualenv
-tox
+futures
pycurl
+tox
twisted
+virtualenv
"
pip install $PIP_PACKAGES
View
3 maint/vm/ubuntu10.04/tox.ini
@@ -15,6 +15,7 @@ deps =
[testenv:py25-full]
basepython = python2.5
deps =
+ futures
pycurl
simplejson
twisted==11.0.0
@@ -26,12 +27,14 @@ deps = unittest2
[testenv:py26-full]
deps =
+ futures
pycurl
twisted==11.0.0
unittest2
[testenv:py27-full]
basepython = python2.7
deps =
+ futures
pycurl
twisted==11.0.0
View
5 maint/vm/ubuntu12.04/setup.sh
@@ -35,10 +35,11 @@ apt-get -y install $DEADSNAKES_PACKAGES
PIP_PACKAGES="
-virtualenv
-tox
+futures
pycurl
+tox
twisted
+virtualenv
"
pip install $PIP_PACKAGES
View
8 maint/vm/ubuntu12.04/tox.ini
@@ -15,18 +15,16 @@ deps =
[testenv:py25-full]
basepython = python2.5
deps =
+ futures
pycurl
simplejson
twisted==11.0.0
unittest2
zope.interface<4.0
-[testenv:py26]
-basepython = python2.6
-deps = unittest2
-
[testenv:py27-full]
basepython = python2.7
deps =
+ futures
pycurl
- twisted==11.0.0
+ twisted==12.2.0

0 comments on commit 3747af5

Please sign in to comment.