RuboCop configuration which has the same code style checking as official Ruby on Rails
Clone or download
toshimaru v1.5.0 release (#33)
* v1.5.0 release

* Update readme
Latest commit 425dd51 Jul 9, 2018

README.md

RuboCop Rails Build Status Gem Version

RuboCop configuration which has the same code style checking as official Ruby on Rails.

⚠️ rubocop-rails is renamed to rubocop-rails_config ⚠️

rubocop-rails is renamed to rubocop-rails_config. To migrate to new gem, install rubocop-rails_config instead of rubocop-rails. See detail here

gem "rubocop-rails_config"

Then, run update command.

$ bundle exec rails generate rubocop_rails_config:update

Sample Pull Request

In this PR, rubocop-rails gem is changed to rubocop-rails_config gem.

https://github.com/toshimaru/RailsTwitterClone/pull/191


Installation

Add this line to your application's Gemfile:

gem "rubocop-rails"

Usage

Add this line to your application's .rubocop.yml, or just run rails generate rubocop_rails:install:

inherit_gem:
  rubocop-rails:
    - config/rails.yml

Customization

If you'd like to customize the rubocop setting, you can override it.

For example, if you want to change TargetRubyVersion, you can do it like:

inherit_gem:
  rubocop-rails:
    - config/rails.yml

AllCops:
  TargetRubyVersion: 2.3

This overrides config/rails.yml setting with TargetRubyVersion: 2.3.

License

The gem is available as open source under the terms of the MIT License.