Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

[BUG] Tox fails to install package with requirements in pyproject.toml #1236

Closed
unmade opened this issue Mar 30, 2019 · 0 comments
Closed

[BUG] Tox fails to install package with requirements in pyproject.toml #1236

unmade opened this issue Mar 30, 2019 · 0 comments
Labels
bug:normal

Comments

@unmade
Copy link
Contributor

@unmade unmade commented Mar 30, 2019

I've been using tox (3.7.0) with flit as a build backend. After upgrading to tox 3.8 I keep getting this error whenever try to run tox:

AttributeError: 'VirtualEnv' object has no attribute 'newaction'

My tox.ini

[tox]
isolated_build = True
envlist =
    test

[tox:.package]
basepython = python3

[testenv]
skip_install = False
deps = 
    pytest
commands = 
    test: pytest -s

My pyproject.toml

[build-system]
requires = ["flit"]
build-backend = "flit.buildapi"

[tool.flit.metadata]
module = "***"
dist-name = "***"
author = "***"
author-email = "***"
requires-python=">=3.7,<4"
description-file="README.md"
requires = [
    "typing-extensions >= 3.7.2,<4",
    "jwcrypto >= 0.6.0,<1",
]

I prepared pull request that fixes this bug: #1235

@unmade unmade added the bug:normal label Mar 30, 2019
@tox-dev tox-dev locked and limited conversation to collaborators Jan 14, 2021
Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
Labels
bug:normal
Projects
None yet
Development

No branches or pull requests

1 participant