Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

JSON output is missing data when using --parallel #1295

Closed
fschulze opened this issue May 14, 2019 · 6 comments · Fixed by #1309
Closed

JSON output is missing data when using --parallel #1295

fschulze opened this issue May 14, 2019 · 6 comments · Fixed by #1309

Comments

@fschulze
Copy link
Contributor

@fschulze fschulze commented May 14, 2019

When using --parallel with --result-json, then the resulting output only contains a setup step and nothing else.

tox.ini

[tox]
envlist = py27,py34,py35,py36

[testenv]
commands = pytest
deps = pytest

setup.py

from setuptools import setup

setup(name='pkg')

test_parallel.py

def test_parallel():
    pass

tox --parallel auto --result-json parallel.json

{
  "reportversion": "1",
  "toxversion": "3.10.0",
  "platform": "darwin",
  "host": "trubel.lan",
  "commands": [
    {
      "command": [
        "/Users/fschulze/temp/tox-parallel-bug/bin/python3.6",
        "setup.py",
        "sdist",
        "--formats=zip",
        "--dist-dir",
        "/Users/fschulze/temp/tox-parallel-bug/.tox/dist"
      ],
      "output": "running sdist\nrunning egg_info\nwriting pkg.egg-info/PKG-INFO\nwriting dependency_links to pkg.egg-info/dependency_links.txt\nwriting top-level names to pkg.egg-info/top_level.txt\nreading manifest file 'pkg.egg-info/SOURCES.txt'\nwriting manifest file 'pkg.egg-info/SOURCES.txt'\nwarning: sdist: standard file not found: should have one of README, README.rst, README.txt, README.md\n\nrunning check\nwarning: check: missing required meta-data: url\n\nwarning: check: missing meta-data: either (author and author_email) or (maintainer and maintainer_email) must be supplied\n\ncreating pkg-0.0.0\ncreating pkg-0.0.0/pkg.egg-info\ncopying files to pkg-0.0.0...\ncopying setup.py -> pkg-0.0.0\ncopying pkg.egg-info/PKG-INFO -> pkg-0.0.0/pkg.egg-info\ncopying pkg.egg-info/SOURCES.txt -> pkg-0.0.0/pkg.egg-info\ncopying pkg.egg-info/dependency_links.txt -> pkg-0.0.0/pkg.egg-info\ncopying pkg.egg-info/top_level.txt -> pkg-0.0.0/pkg.egg-info\nWriting pkg-0.0.0/setup.cfg\ncreating /Users/fschulze/temp/tox-parallel-bug/.tox/dist\ncreating '/Users/fschulze/temp/tox-parallel-bug/.tox/dist/pkg-0.0.0.zip' and adding 'pkg-0.0.0' to it\nadding 'pkg-0.0.0'\nadding 'pkg-0.0.0/pkg.egg-info'\nadding 'pkg-0.0.0/PKG-INFO'\nadding 'pkg-0.0.0/setup.py'\nadding 'pkg-0.0.0/setup.cfg'\nadding 'pkg-0.0.0/pkg.egg-info/PKG-INFO'\nadding 'pkg-0.0.0/pkg.egg-info/SOURCES.txt'\nadding 'pkg-0.0.0/pkg.egg-info/top_level.txt'\nadding 'pkg-0.0.0/pkg.egg-info/dependency_links.txt'\nremoving 'pkg-0.0.0' (and everything under it)\n",
      "retcode": 0
    }
  ],
  "testenvs": {
    "py27": {
      "setup": [
        {
          "command": [
            "/Users/fschulze/temp/tox-parallel-bug/bin/python3.6",
            "lib/python3.6/site-packages/tox/__main__.py",
            "--parallel",
            "auto",
            "--result-json",
            "parallel.json",
            "--installpkg",
            ".tox/.tmp/package/1/pkg-0.0.0.zip"
          ],
          "output": "py27 create: /Users/fschulze/temp/tox-parallel-bug/.tox/py27\npy27 installdeps: pytest\npy27 inst: /Users/fschulze/temp/tox-parallel-bug/.tox/.tmp/package/2/pkg-0.0.0.zip\npy27 installed: DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7.,atomicwrites==1.3.0,attrs==19.1.0,funcsigs==1.0.2,more-itertools==5.0.0,pathlib2==2.3.3,pkg==0.0.0,pluggy==0.11.0,py==1.8.0,pytest==4.5.0,scandir==1.10.0,six==1.12.0,wcwidth==0.1.7\npy27 run-test-pre: PYTHONHASHSEED='2057909101'\npy27 run-test: commands[0] | pytest\n============================= test session starts ==============================\nplatform darwin -- Python 2.7.16, pytest-4.5.0, py-1.8.0, pluggy-0.11.0\ncachedir: .tox/py27/.pytest_cache\nrootdir: /Users/fschulze/temp/tox-parallel-bug\ncollected 1 item\n\ntest_parallel.py .                                                       [100%]\n\n=========================== 1 passed in 0.53 seconds ===========================\n",
          "retcode": 0
        }
      ]
    },
    "py34": {
      "setup": [
        {
          "command": [
            "/Users/fschulze/temp/tox-parallel-bug/bin/python3.6",
            "lib/python3.6/site-packages/tox/__main__.py",
            "--parallel",
            "auto",
            "--result-json",
            "parallel.json",
            "--installpkg",
            ".tox/.tmp/package/1/pkg-0.0.0.zip"
          ],
          "output": "py34 create: /Users/fschulze/temp/tox-parallel-bug/.tox/py34\npy34 installdeps: pytest\npy34 inst: /Users/fschulze/temp/tox-parallel-bug/.tox/.tmp/package/3/pkg-0.0.0.zip\npy34 installed: DEPRECATION: Python 3.4 support has been deprecated. pip 19.1 will be the last one supporting it. Please upgrade your Python as Python 3.4 won't be maintained after March 2019 (cf PEP 429).,atomicwrites==1.3.0,attrs==19.1.0,more-itertools==7.0.0,pathlib2==2.3.3,pkg==0.0.0,pluggy==0.11.0,py==1.8.0,pytest==4.5.0,scandir==1.10.0,six==1.12.0,wcwidth==0.1.7\npy34 run-test-pre: PYTHONHASHSEED='2275688607'\npy34 run-test: commands[0] | pytest\n============================= test session starts ==============================\nplatform darwin -- Python 3.4.10, pytest-4.5.0, py-1.8.0, pluggy-0.11.0\ncachedir: .tox/py34/.pytest_cache\nrootdir: /Users/fschulze/temp/tox-parallel-bug\ncollected 1 item\n\ntest_parallel.py .                                                       [100%]\n\n=========================== 1 passed in 0.88 seconds ===========================\n",
          "retcode": 0
        }
      ]
    },
    "py35": {
      "setup": [
        {
          "command": [
            "/Users/fschulze/temp/tox-parallel-bug/bin/python3.6",
            "lib/python3.6/site-packages/tox/__main__.py",
            "--parallel",
            "auto",
            "--result-json",
            "parallel.json",
            "--installpkg",
            ".tox/.tmp/package/1/pkg-0.0.0.zip"
          ],
          "output": "lock file /Users/fschulze/temp/tox-parallel-bug/.tox/.package.lock present, will block until released\npy35 create: /Users/fschulze/temp/tox-parallel-bug/.tox/py35\npy35 installdeps: pytest\npy35 inst: /Users/fschulze/temp/tox-parallel-bug/.tox/.tmp/package/5/pkg-0.0.0.zip\npy35 installed: atomicwrites==1.3.0,attrs==19.1.0,more-itertools==7.0.0,pathlib2==2.3.3,pkg==0.0.0,pluggy==0.11.0,py==1.8.0,pytest==4.5.0,six==1.12.0,wcwidth==0.1.7\npy35 run-test-pre: PYTHONHASHSEED='3615813061'\npy35 run-test: commands[0] | pytest\n============================= test session starts ==============================\nplatform darwin -- Python 3.5.7, pytest-4.5.0, py-1.8.0, pluggy-0.11.0\ncachedir: .tox/py35/.pytest_cache\nrootdir: /Users/fschulze/temp/tox-parallel-bug\ncollected 1 item\n\ntest_parallel.py .                                                       [100%]\n\n=========================== 1 passed in 0.82 seconds ===========================\n",
          "retcode": 0
        }
      ]
    },
    "py36": {
      "setup": [
        {
          "command": [
            "/Users/fschulze/temp/tox-parallel-bug/bin/python3.6",
            "lib/python3.6/site-packages/tox/__main__.py",
            "--parallel",
            "auto",
            "--result-json",
            "parallel.json",
            "--installpkg",
            ".tox/.tmp/package/1/pkg-0.0.0.zip"
          ],
          "output": "py36 create: /Users/fschulze/temp/tox-parallel-bug/.tox/py36\npy36 installdeps: pytest\npy36 inst: /Users/fschulze/temp/tox-parallel-bug/.tox/.tmp/package/4/pkg-0.0.0.zip\npy36 installed: atomicwrites==1.3.0,attrs==19.1.0,more-itertools==7.0.0,pkg==0.0.0,pluggy==0.11.0,py==1.8.0,pytest==4.5.0,six==1.12.0,wcwidth==0.1.7\npy36 run-test-pre: PYTHONHASHSEED='3237041776'\npy36 run-test: commands[0] | pytest\n============================= test session starts ==============================\nplatform darwin -- Python 3.6.8, pytest-4.5.0, py-1.8.0, pluggy-0.11.0\ncachedir: .tox/py36/.pytest_cache\nrootdir: /Users/fschulze/temp/tox-parallel-bug\ncollected 1 item\n\ntest_parallel.py .                                                       [100%]\n\n=========================== 1 passed in 0.87 seconds ===========================\n",
          "retcode": 0
        }
      ]
    }
  }
}

% tox --result-json serial.json

{
  "reportversion": "1",
  "toxversion": "3.10.0",
  "platform": "darwin",
  "host": "trubel.lan",
  "commands": [
    {
      "command": [
        "/Users/fschulze/temp/tox-parallel-bug/bin/python3.6",
        "setup.py",
        "sdist",
        "--formats=zip",
        "--dist-dir",
        "/Users/fschulze/temp/tox-parallel-bug/.tox/dist"
      ],
      "output": "running sdist\nrunning egg_info\nwriting pkg.egg-info/PKG-INFO\nwriting dependency_links to pkg.egg-info/dependency_links.txt\nwriting top-level names to pkg.egg-info/top_level.txt\nreading manifest file 'pkg.egg-info/SOURCES.txt'\nwriting manifest file 'pkg.egg-info/SOURCES.txt'\nwarning: sdist: standard file not found: should have one of README, README.rst, README.txt, README.md\n\nrunning check\nwarning: check: missing required meta-data: url\n\nwarning: check: missing meta-data: either (author and author_email) or (maintainer and maintainer_email) must be supplied\n\ncreating pkg-0.0.0\ncreating pkg-0.0.0/pkg.egg-info\ncopying files to pkg-0.0.0...\ncopying setup.py -> pkg-0.0.0\ncopying pkg.egg-info/PKG-INFO -> pkg-0.0.0/pkg.egg-info\ncopying pkg.egg-info/SOURCES.txt -> pkg-0.0.0/pkg.egg-info\ncopying pkg.egg-info/dependency_links.txt -> pkg-0.0.0/pkg.egg-info\ncopying pkg.egg-info/top_level.txt -> pkg-0.0.0/pkg.egg-info\nWriting pkg-0.0.0/setup.cfg\ncreating /Users/fschulze/temp/tox-parallel-bug/.tox/dist\ncreating '/Users/fschulze/temp/tox-parallel-bug/.tox/dist/pkg-0.0.0.zip' and adding 'pkg-0.0.0' to it\nadding 'pkg-0.0.0'\nadding 'pkg-0.0.0/pkg.egg-info'\nadding 'pkg-0.0.0/PKG-INFO'\nadding 'pkg-0.0.0/setup.py'\nadding 'pkg-0.0.0/setup.cfg'\nadding 'pkg-0.0.0/pkg.egg-info/PKG-INFO'\nadding 'pkg-0.0.0/pkg.egg-info/SOURCES.txt'\nadding 'pkg-0.0.0/pkg.egg-info/top_level.txt'\nadding 'pkg-0.0.0/pkg.egg-info/dependency_links.txt'\nremoving 'pkg-0.0.0' (and everything under it)\n",
      "retcode": 0
    }
  ],
  "testenvs": {
    "py27": {
      "setup": [
        {
          "command": [
            "/Users/fschulze/temp/tox-parallel-bug/bin/python3.6",
            "-m",
            "virtualenv",
            "--no-download",
            "--python",
            "/Users/fschulze/.pyenv/versions/2.7.16/bin/python2.7",
            "py27"
          ],
          "output": "New python executable in /Users/fschulze/temp/tox-parallel-bug/.tox/py27/bin/python2.7\nAlso creating executable in /Users/fschulze/temp/tox-parallel-bug/.tox/py27/bin/python\nPlease make sure you remove any previous custom paths from your /Users/fschulze/.pydistutils.cfg file.\nInstalling setuptools, pip, wheel...\ndone.\nRunning virtualenv with interpreter /Users/fschulze/.pyenv/versions/2.7.16/bin/python2.7\n",
          "retcode": 0
        },
        {
          "command": [
            "/Users/fschulze/temp/tox-parallel-bug/.tox/py27/bin/python",
            "-m",
            "pip",
            "install",
            "pytest"
          ],
          "output": "DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7.\nLooking in indexes: https://d.rzon.de:8141/fschulze/dev/+simple/\nCollecting pytest\n  Using cached https://d.rzon.de:8141/root/pypi/%2Bf/b8b/f138592384bd4/pytest-4.5.0-py2.py3-none-any.whl\nCollecting more-itertools<6.0.0,>=4.0.0; python_version <= \"2.7\" (from pytest)\n  Using cached https://d.rzon.de:8141/root/pypi/%2Bf/c0a/5785b1109a6bd/more_itertools-5.0.0-py2-none-any.whl\nCollecting funcsigs>=1.0; python_version < \"3.0\" (from pytest)\n  Using cached https://d.rzon.de:8141/root/pypi/%2Bf/330/cc27ccbf7f1e9/funcsigs-1.0.2-py2.py3-none-any.whl\nCollecting atomicwrites>=1.0 (from pytest)\n  Using cached https://d.rzon.de:8141/root/pypi/%2Bf/034/72c30eb2c5d1b/atomicwrites-1.3.0-py2.py3-none-any.whl\nCollecting six>=1.10.0 (from pytest)\n  Using cached https://d.rzon.de:8141/root/pypi/%2Bf/335/0809f0555b11f/six-1.12.0-py2.py3-none-any.whl\nRequirement already satisfied: setuptools in ./.tox/py27/lib/python2.7/site-packages (from pytest) (41.0.1)\nCollecting attrs>=17.4.0 (from pytest)\n  Using cached https://d.rzon.de:8141/root/pypi/%2Bf/69c/0dbf2ed392de1/attrs-19.1.0-py2.py3-none-any.whl\nCollecting wcwidth (from pytest)\n  Using cached https://d.rzon.de:8141/root/pypi/%2Bf/f4e/be71925af7b40/wcwidth-0.1.7-py2.py3-none-any.whl\nCollecting py>=1.5.0 (from pytest)\n  Using cached https://d.rzon.de:8141/root/pypi/%2Bf/64f/65755aee5b381/py-1.8.0-py2.py3-none-any.whl\nCollecting pathlib2>=2.2.0; python_version < \"3.6\" (from pytest)\n  Using cached https://d.rzon.de:8141/root/pypi/%2Bf/588/7121d7f7df360/pathlib2-2.3.3-py2.py3-none-any.whl\nCollecting pluggy!=0.10,<1.0,>=0.9 (from pytest)\n  Using cached https://d.rzon.de:8141/root/pypi/%2Bf/964/cedd2b27c492f/pluggy-0.11.0-py2.py3-none-any.whl\nCollecting scandir; python_version < \"3.5\" (from pathlib2>=2.2.0; python_version < \"3.6\"->pytest)\nInstalling collected packages: six, more-itertools, funcsigs, atomicwrites, attrs, wcwidth, py, scandir, pathlib2, pluggy, pytest\nSuccessfully installed atomicwrites-1.3.0 attrs-19.1.0 funcsigs-1.0.2 more-itertools-5.0.0 pathlib2-2.3.3 pluggy-0.11.0 py-1.8.0 pytest-4.5.0 scandir-1.10.0 six-1.12.0 wcwidth-0.1.7\nWARNING: You are using pip version 19.1, however version 19.1.1 is available.\nYou should consider upgrading via the 'pip install --upgrade pip' command.\n",
          "retcode": 0
        },
        {
          "command": [
            "/Users/fschulze/temp/tox-parallel-bug/.tox/py27/bin/python",
            "-m",
            "pip",
            "install",
            "--exists-action",
            "w",
            ".tox/.tmp/package/1/pkg-0.0.0.zip"
          ],
          "output": "DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7.\nLooking in indexes: https://d.rzon.de:8141/fschulze/dev/+simple/\nProcessing ./.tox/.tmp/package/1/pkg-0.0.0.zip\nBuilding wheels for collected packages: pkg\n  Building wheel for pkg (setup.py): started\n  Building wheel for pkg (setup.py): finished with status 'done'\n  Stored in directory: /Users/fschulze/Library/Caches/pip/wheels/33/14/3d/d149baf4774bff69b894455fdb8825c9eadc54cd4afa48185c\nSuccessfully built pkg\nInstalling collected packages: pkg\n  Found existing installation: pkg 0.0.0\n    Not uninstalling pkg at /Users/fschulze/temp/tox-parallel-bug, outside environment /Users/fschulze/temp/tox-parallel-bug/.tox/py27\n    Can't uninstall 'pkg'. No files were found to uninstall.\nSuccessfully installed pkg-0.0.0\nWARNING: You are using pip version 19.1, however version 19.1.1 is available.\nYou should consider upgrading via the 'pip install --upgrade pip' command.\n",
          "retcode": 0
        },
        {
          "command": [
            "/Users/fschulze/temp/tox-parallel-bug/.tox/py27/bin/python",
            "-m",
            "pip",
            "freeze"
          ],
          "output": "DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7.\natomicwrites==1.3.0\nattrs==19.1.0\nfuncsigs==1.0.2\nmore-itertools==5.0.0\npathlib2==2.3.3\npkg==0.0.0\npluggy==0.11.0\npy==1.8.0\npytest==4.5.0\nscandir==1.10.0\nsix==1.12.0\nwcwidth==0.1.7\n",
          "retcode": 0
        }
      ],
      "python": {
        "executable": "/Users/fschulze/temp/tox-parallel-bug/.tox/py27/bin/python",
        "name": "python",
        "version_info": [
          2,
          7,
          16,
          "final",
          0
        ],
        "sysplatform": "darwin",
        "version": "2.7.16 (default, Apr 30 2019, 16:52:02) \n[GCC 4.2.1 Compatible Apple LLVM 10.0.1 (clang-1001.0.46.4)]",
        "is_64": true
      },
      "installpkg": {
        "md5": "c8385466301580b8f5591ae03bf8a107",
        "sha256": "b0fb48df1d530131226dd4216386a8701db7278d2532fab458558ee38e6d53c9",
        "basename": "pkg-0.0.0.zip"
      },
      "installed_packages": [
        "DEPRECATION: Python 2.7 will reach the end of its life on January 1st, 2020. Please upgrade your Python as Python 2.7 won't be maintained after that date. A future version of pip will drop support for Python 2.7.",
        "atomicwrites==1.3.0",
        "attrs==19.1.0",
        "funcsigs==1.0.2",
        "more-itertools==5.0.0",
        "pathlib2==2.3.3",
        "pkg==0.0.0",
        "pluggy==0.11.0",
        "py==1.8.0",
        "pytest==4.5.0",
        "scandir==1.10.0",
        "six==1.12.0",
        "wcwidth==0.1.7"
      ],
      "test": [
        {
          "command": [
            "/Users/fschulze/temp/tox-parallel-bug/.tox/py27/bin/pytest"
          ],
          "output": "============================= test session starts ==============================\nplatform darwin -- Python 2.7.16, pytest-4.5.0, py-1.8.0, pluggy-0.11.0\ncachedir: .tox/py27/.pytest_cache\nrootdir: /Users/fschulze/temp/tox-parallel-bug\ncollected 1 item\n\ntest_parallel.py .                                                       [100%]\n\n=========================== 1 passed in 0.40 seconds ===========================\n",
          "retcode": 0
        }
      ]
    },
    "py34": {
      "setup": [
        {
          "command": [
            "/Users/fschulze/temp/tox-parallel-bug/bin/python3.6",
            "-m",
            "virtualenv",
            "--no-download",
            "--python",
            "/Users/fschulze/.pyenv/versions/3.4.10/bin/python3.4",
            "py34"
          ],
          "output": "Using base prefix '/Users/fschulze/.pyenv/versions/3.4.10'\nNew python executable in /Users/fschulze/temp/tox-parallel-bug/.tox/py34/bin/python3.4\nAlso creating executable in /Users/fschulze/temp/tox-parallel-bug/.tox/py34/bin/python\nPlease make sure you remove any previous custom paths from your /Users/fschulze/.pydistutils.cfg file.\nInstalling setuptools, pip, wheel...\ndone.\nRunning virtualenv with interpreter /Users/fschulze/.pyenv/versions/3.4.10/bin/python3.4\n",
          "retcode": 0
        },
        {
          "command": [
            "/Users/fschulze/temp/tox-parallel-bug/.tox/py34/bin/python",
            "-m",
            "pip",
            "install",
            "pytest"
          ],
          "output": "DEPRECATION: Python 3.4 support has been deprecated. pip 19.1 will be the last one supporting it. Please upgrade your Python as Python 3.4 won't be maintained after March 2019 (cf PEP 429).\nLooking in indexes: https://d.rzon.de:8141/fschulze/dev/+simple/\nCollecting pytest\n  Using cached https://d.rzon.de:8141/root/pypi/%2Bf/b8b/f138592384bd4/pytest-4.5.0-py2.py3-none-any.whl\nCollecting pluggy!=0.10,<1.0,>=0.9 (from pytest)\n  Using cached https://d.rzon.de:8141/root/pypi/%2Bf/964/cedd2b27c492f/pluggy-0.11.0-py2.py3-none-any.whl\nCollecting attrs>=17.4.0 (from pytest)\n  Using cached https://d.rzon.de:8141/root/pypi/%2Bf/69c/0dbf2ed392de1/attrs-19.1.0-py2.py3-none-any.whl\nCollecting more-itertools>=4.0.0; python_version > \"2.7\" (from pytest)\n  Using cached https://d.rzon.de:8141/root/pypi/%2Bf/211/2d2ca570bb7c3/more_itertools-7.0.0-py3-none-any.whl\nCollecting atomicwrites>=1.0 (from pytest)\n  Using cached https://d.rzon.de:8141/root/pypi/%2Bf/034/72c30eb2c5d1b/atomicwrites-1.3.0-py2.py3-none-any.whl\nCollecting wcwidth (from pytest)\n  Using cached https://d.rzon.de:8141/root/pypi/%2Bf/f4e/be71925af7b40/wcwidth-0.1.7-py2.py3-none-any.whl\nCollecting six>=1.10.0 (from pytest)\n  Using cached https://d.rzon.de:8141/root/pypi/%2Bf/335/0809f0555b11f/six-1.12.0-py2.py3-none-any.whl\nRequirement already satisfied: setuptools in ./.tox/py34/lib/python3.4/site-packages (from pytest) (41.0.1)\nCollecting pathlib2>=2.2.0; python_version < \"3.6\" (from pytest)\n  Using cached https://d.rzon.de:8141/root/pypi/%2Bf/588/7121d7f7df360/pathlib2-2.3.3-py2.py3-none-any.whl\nCollecting py>=1.5.0 (from pytest)\n  Using cached https://d.rzon.de:8141/root/pypi/%2Bf/64f/65755aee5b381/py-1.8.0-py2.py3-none-any.whl\nCollecting scandir; python_version < \"3.5\" (from pathlib2>=2.2.0; python_version < \"3.6\"->pytest)\nInstalling collected packages: pluggy, attrs, more-itertools, atomicwrites, wcwidth, six, scandir, pathlib2, py, pytest\nSuccessfully installed atomicwrites-1.3.0 attrs-19.1.0 more-itertools-7.0.0 pathlib2-2.3.3 pluggy-0.11.0 py-1.8.0 pytest-4.5.0 scandir-1.10.0 six-1.12.0 wcwidth-0.1.7\nWARNING: You are using pip version 19.1, however version 19.1.1 is available.\nYou should consider upgrading via the 'pip install --upgrade pip' command.\n",
          "retcode": 0
        },
        {
          "command": [
            "/Users/fschulze/temp/tox-parallel-bug/.tox/py34/bin/python",
            "-m",
            "pip",
            "install",
            "--exists-action",
            "w",
            ".tox/.tmp/package/1/pkg-0.0.0.zip"
          ],
          "output": "DEPRECATION: Python 3.4 support has been deprecated. pip 19.1 will be the last one supporting it. Please upgrade your Python as Python 3.4 won't be maintained after March 2019 (cf PEP 429).\nLooking in indexes: https://d.rzon.de:8141/fschulze/dev/+simple/\nProcessing ./.tox/.tmp/package/1/pkg-0.0.0.zip\nBuilding wheels for collected packages: pkg\n  Building wheel for pkg (setup.py): started\n  Building wheel for pkg (setup.py): finished with status 'done'\n  Stored in directory: /Users/fschulze/Library/Caches/pip/wheels/33/14/3d/d149baf4774bff69b894455fdb8825c9eadc54cd4afa48185c\nSuccessfully built pkg\nInstalling collected packages: pkg\n  Found existing installation: pkg 0.0.0\n    Not uninstalling pkg at /Users/fschulze/temp/tox-parallel-bug, outside environment /Users/fschulze/temp/tox-parallel-bug/.tox/py34\n    Can't uninstall 'pkg'. No files were found to uninstall.\nSuccessfully installed pkg-0.0.0\nWARNING: You are using pip version 19.1, however version 19.1.1 is available.\nYou should consider upgrading via the 'pip install --upgrade pip' command.\n",
          "retcode": 0
        },
        {
          "command": [
            "/Users/fschulze/temp/tox-parallel-bug/.tox/py34/bin/python",
            "-m",
            "pip",
            "freeze"
          ],
          "output": "DEPRECATION: Python 3.4 support has been deprecated. pip 19.1 will be the last one supporting it. Please upgrade your Python as Python 3.4 won't be maintained after March 2019 (cf PEP 429).\natomicwrites==1.3.0\nattrs==19.1.0\nmore-itertools==7.0.0\npathlib2==2.3.3\npkg==0.0.0\npluggy==0.11.0\npy==1.8.0\npytest==4.5.0\nscandir==1.10.0\nsix==1.12.0\nwcwidth==0.1.7\n",
          "retcode": 0
        }
      ],
      "python": {
        "version": "3.4.10 (default, Apr 30 2019, 17:06:37) \n[GCC 4.2.1 Compatible Apple LLVM 10.0.1 (clang-1001.0.46.4)]",
        "version_info": [
          3,
          4,
          10,
          "final",
          0
        ],
        "executable": "/Users/fschulze/temp/tox-parallel-bug/.tox/py34/bin/python",
        "name": "python",
        "is_64": true,
        "sysplatform": "darwin"
      },
      "installpkg": {
        "md5": "c8385466301580b8f5591ae03bf8a107",
        "sha256": "b0fb48df1d530131226dd4216386a8701db7278d2532fab458558ee38e6d53c9",
        "basename": "pkg-0.0.0.zip"
      },
      "installed_packages": [
        "DEPRECATION: Python 3.4 support has been deprecated. pip 19.1 will be the last one supporting it. Please upgrade your Python as Python 3.4 won't be maintained after March 2019 (cf PEP 429).",
        "atomicwrites==1.3.0",
        "attrs==19.1.0",
        "more-itertools==7.0.0",
        "pathlib2==2.3.3",
        "pkg==0.0.0",
        "pluggy==0.11.0",
        "py==1.8.0",
        "pytest==4.5.0",
        "scandir==1.10.0",
        "six==1.12.0",
        "wcwidth==0.1.7"
      ],
      "test": [
        {
          "command": [
            "/Users/fschulze/temp/tox-parallel-bug/.tox/py34/bin/pytest"
          ],
          "output": "============================= test session starts ==============================\nplatform darwin -- Python 3.4.10, pytest-4.5.0, py-1.8.0, pluggy-0.11.0\ncachedir: .tox/py34/.pytest_cache\nrootdir: /Users/fschulze/temp/tox-parallel-bug\ncollected 1 item\n\ntest_parallel.py .                                                       [100%]\n\n=========================== 1 passed in 0.84 seconds ===========================\n",
          "retcode": 0
        }
      ]
    },
    "py35": {
      "setup": [
        {
          "command": [
            "/Users/fschulze/temp/tox-parallel-bug/bin/python3.6",
            "-m",
            "virtualenv",
            "--no-download",
            "--python",
            "/Users/fschulze/.pyenv/versions/3.5.7/bin/python3.5",
            "py35"
          ],
          "output": "Using base prefix '/Users/fschulze/.pyenv/versions/3.5.7'\nNew python executable in /Users/fschulze/temp/tox-parallel-bug/.tox/py35/bin/python3.5\nAlso creating executable in /Users/fschulze/temp/tox-parallel-bug/.tox/py35/bin/python\nPlease make sure you remove any previous custom paths from your /Users/fschulze/.pydistutils.cfg file.\nInstalling setuptools, pip, wheel...\ndone.\nRunning virtualenv with interpreter /Users/fschulze/.pyenv/versions/3.5.7/bin/python3.5\n",
          "retcode": 0
        },
        {
          "command": [
            "/Users/fschulze/temp/tox-parallel-bug/.tox/py35/bin/python",
            "-m",
            "pip",
            "install",
            "pytest"
          ],
          "output": "Looking in indexes: https://d.rzon.de:8141/fschulze/dev/+simple/\nCollecting pytest\n  Using cached https://d.rzon.de:8141/root/pypi/%2Bf/b8b/f138592384bd4/pytest-4.5.0-py2.py3-none-any.whl\nCollecting atomicwrites>=1.0 (from pytest)\n  Using cached https://d.rzon.de:8141/root/pypi/%2Bf/034/72c30eb2c5d1b/atomicwrites-1.3.0-py2.py3-none-any.whl\nCollecting wcwidth (from pytest)\n  Using cached https://d.rzon.de:8141/root/pypi/%2Bf/f4e/be71925af7b40/wcwidth-0.1.7-py2.py3-none-any.whl\nCollecting six>=1.10.0 (from pytest)\n  Using cached https://d.rzon.de:8141/root/pypi/%2Bf/335/0809f0555b11f/six-1.12.0-py2.py3-none-any.whl\nCollecting more-itertools>=4.0.0; python_version > \"2.7\" (from pytest)\n  Using cached https://d.rzon.de:8141/root/pypi/%2Bf/211/2d2ca570bb7c3/more_itertools-7.0.0-py3-none-any.whl\nCollecting py>=1.5.0 (from pytest)\n  Using cached https://d.rzon.de:8141/root/pypi/%2Bf/64f/65755aee5b381/py-1.8.0-py2.py3-none-any.whl\nCollecting attrs>=17.4.0 (from pytest)\n  Using cached https://d.rzon.de:8141/root/pypi/%2Bf/69c/0dbf2ed392de1/attrs-19.1.0-py2.py3-none-any.whl\nRequirement already satisfied: setuptools in ./.tox/py35/lib/python3.5/site-packages (from pytest) (41.0.1)\nCollecting pathlib2>=2.2.0; python_version < \"3.6\" (from pytest)\n  Using cached https://d.rzon.de:8141/root/pypi/%2Bf/588/7121d7f7df360/pathlib2-2.3.3-py2.py3-none-any.whl\nCollecting pluggy!=0.10,<1.0,>=0.9 (from pytest)\n  Using cached https://d.rzon.de:8141/root/pypi/%2Bf/964/cedd2b27c492f/pluggy-0.11.0-py2.py3-none-any.whl\nInstalling collected packages: atomicwrites, wcwidth, six, more-itertools, py, attrs, pathlib2, pluggy, pytest\nSuccessfully installed atomicwrites-1.3.0 attrs-19.1.0 more-itertools-7.0.0 pathlib2-2.3.3 pluggy-0.11.0 py-1.8.0 pytest-4.5.0 six-1.12.0 wcwidth-0.1.7\nWARNING: You are using pip version 19.1, however version 19.1.1 is available.\nYou should consider upgrading via the 'pip install --upgrade pip' command.\n",
          "retcode": 0
        },
        {
          "command": [
            "/Users/fschulze/temp/tox-parallel-bug/.tox/py35/bin/python",
            "-m",
            "pip",
            "install",
            "--exists-action",
            "w",
            ".tox/.tmp/package/1/pkg-0.0.0.zip"
          ],
          "output": "Looking in indexes: https://d.rzon.de:8141/fschulze/dev/+simple/\nProcessing ./.tox/.tmp/package/1/pkg-0.0.0.zip\nBuilding wheels for collected packages: pkg\n  Building wheel for pkg (setup.py): started\n  Building wheel for pkg (setup.py): finished with status 'done'\n  Stored in directory: /Users/fschulze/Library/Caches/pip/wheels/33/14/3d/d149baf4774bff69b894455fdb8825c9eadc54cd4afa48185c\nSuccessfully built pkg\nInstalling collected packages: pkg\n  Found existing installation: pkg 0.0.0\n    Not uninstalling pkg at /Users/fschulze/temp/tox-parallel-bug, outside environment /Users/fschulze/temp/tox-parallel-bug/.tox/py35\n    Can't uninstall 'pkg'. No files were found to uninstall.\nSuccessfully installed pkg-0.0.0\nWARNING: You are using pip version 19.1, however version 19.1.1 is available.\nYou should consider upgrading via the 'pip install --upgrade pip' command.\n",
          "retcode": 0
        },
        {
          "command": [
            "/Users/fschulze/temp/tox-parallel-bug/.tox/py35/bin/python",
            "-m",
            "pip",
            "freeze"
          ],
          "output": "atomicwrites==1.3.0\nattrs==19.1.0\nmore-itertools==7.0.0\npathlib2==2.3.3\npkg==0.0.0\npluggy==0.11.0\npy==1.8.0\npytest==4.5.0\nsix==1.12.0\nwcwidth==0.1.7\n",
          "retcode": 0
        }
      ],
      "python": {
        "is_64": true,
        "name": "python",
        "version_info": [
          3,
          5,
          7,
          "final",
          0
        ],
        "executable": "/Users/fschulze/temp/tox-parallel-bug/.tox/py35/bin/python",
        "sysplatform": "darwin",
        "version": "3.5.7 (default, Apr 30 2019, 17:06:49) \n[GCC 4.2.1 Compatible Apple LLVM 10.0.1 (clang-1001.0.46.4)]"
      },
      "installpkg": {
        "md5": "c8385466301580b8f5591ae03bf8a107",
        "sha256": "b0fb48df1d530131226dd4216386a8701db7278d2532fab458558ee38e6d53c9",
        "basename": "pkg-0.0.0.zip"
      },
      "installed_packages": [
        "atomicwrites==1.3.0",
        "attrs==19.1.0",
        "more-itertools==7.0.0",
        "pathlib2==2.3.3",
        "pkg==0.0.0",
        "pluggy==0.11.0",
        "py==1.8.0",
        "pytest==4.5.0",
        "six==1.12.0",
        "wcwidth==0.1.7"
      ],
      "test": [
        {
          "command": [
            "/Users/fschulze/temp/tox-parallel-bug/.tox/py35/bin/pytest"
          ],
          "output": "============================= test session starts ==============================\nplatform darwin -- Python 3.5.7, pytest-4.5.0, py-1.8.0, pluggy-0.11.0\ncachedir: .tox/py35/.pytest_cache\nrootdir: /Users/fschulze/temp/tox-parallel-bug\ncollected 1 item\n\ntest_parallel.py .                                                       [100%]\n\n=========================== 1 passed in 0.77 seconds ===========================\n",
          "retcode": 0
        }
      ]
    },
    "py36": {
      "setup": [
        {
          "command": [
            "/Users/fschulze/temp/tox-parallel-bug/bin/python3.6",
            "-m",
            "virtualenv",
            "--no-download",
            "--python",
            "/Users/fschulze/temp/tox-parallel-bug/bin/python3.6",
            "py36"
          ],
          "output": "Already using interpreter /Users/fschulze/temp/tox-parallel-bug/bin/python3.6\nUsing real prefix '/Users/fschulze/.pyenv/versions/3.6.8'\nNew python executable in /Users/fschulze/temp/tox-parallel-bug/.tox/py36/bin/python3.6\nAlso creating executable in /Users/fschulze/temp/tox-parallel-bug/.tox/py36/bin/python\nPlease make sure you remove any previous custom paths from your /Users/fschulze/.pydistutils.cfg file.\nInstalling setuptools, pip, wheel...\ndone.\n",
          "retcode": 0
        },
        {
          "command": [
            "/Users/fschulze/temp/tox-parallel-bug/.tox/py36/bin/python",
            "-m",
            "pip",
            "install",
            "pytest"
          ],
          "output": "Looking in indexes: https://d.rzon.de:8141/fschulze/dev/+simple/\nCollecting pytest\n  Using cached https://d.rzon.de:8141/root/pypi/%2Bf/b8b/f138592384bd4/pytest-4.5.0-py2.py3-none-any.whl\nCollecting py>=1.5.0 (from pytest)\n  Using cached https://d.rzon.de:8141/root/pypi/%2Bf/64f/65755aee5b381/py-1.8.0-py2.py3-none-any.whl\nCollecting atomicwrites>=1.0 (from pytest)\n  Using cached https://d.rzon.de:8141/root/pypi/%2Bf/034/72c30eb2c5d1b/atomicwrites-1.3.0-py2.py3-none-any.whl\nCollecting pluggy!=0.10,<1.0,>=0.9 (from pytest)\n  Using cached https://d.rzon.de:8141/root/pypi/%2Bf/964/cedd2b27c492f/pluggy-0.11.0-py2.py3-none-any.whl\nCollecting six>=1.10.0 (from pytest)\n  Using cached https://d.rzon.de:8141/root/pypi/%2Bf/335/0809f0555b11f/six-1.12.0-py2.py3-none-any.whl\nCollecting attrs>=17.4.0 (from pytest)\n  Using cached https://d.rzon.de:8141/root/pypi/%2Bf/69c/0dbf2ed392de1/attrs-19.1.0-py2.py3-none-any.whl\nRequirement already satisfied: setuptools in ./.tox/py36/lib/python3.6/site-packages (from pytest) (41.0.1)\nCollecting more-itertools>=4.0.0; python_version > \"2.7\" (from pytest)\n  Using cached https://d.rzon.de:8141/root/pypi/%2Bf/211/2d2ca570bb7c3/more_itertools-7.0.0-py3-none-any.whl\nCollecting wcwidth (from pytest)\n  Using cached https://d.rzon.de:8141/root/pypi/%2Bf/f4e/be71925af7b40/wcwidth-0.1.7-py2.py3-none-any.whl\nInstalling collected packages: py, atomicwrites, pluggy, six, attrs, more-itertools, wcwidth, pytest\nSuccessfully installed atomicwrites-1.3.0 attrs-19.1.0 more-itertools-7.0.0 pluggy-0.11.0 py-1.8.0 pytest-4.5.0 six-1.12.0 wcwidth-0.1.7\nWARNING: You are using pip version 19.1, however version 19.1.1 is available.\nYou should consider upgrading via the 'pip install --upgrade pip' command.\n",
          "retcode": 0
        },
        {
          "command": [
            "/Users/fschulze/temp/tox-parallel-bug/.tox/py36/bin/python",
            "-m",
            "pip",
            "install",
            "--exists-action",
            "w",
            ".tox/.tmp/package/1/pkg-0.0.0.zip"
          ],
          "output": "Looking in indexes: https://d.rzon.de:8141/fschulze/dev/+simple/\nProcessing ./.tox/.tmp/package/1/pkg-0.0.0.zip\nBuilding wheels for collected packages: pkg\n  Building wheel for pkg (setup.py): started\n  Building wheel for pkg (setup.py): finished with status 'done'\n  Stored in directory: /Users/fschulze/Library/Caches/pip/wheels/33/14/3d/d149baf4774bff69b894455fdb8825c9eadc54cd4afa48185c\nSuccessfully built pkg\nInstalling collected packages: pkg\n  Found existing installation: pkg 0.0.0\n    Not uninstalling pkg at /Users/fschulze/temp/tox-parallel-bug, outside environment /Users/fschulze/temp/tox-parallel-bug/.tox/py36\n    Can't uninstall 'pkg'. No files were found to uninstall.\nSuccessfully installed pkg-0.0.0\nWARNING: You are using pip version 19.1, however version 19.1.1 is available.\nYou should consider upgrading via the 'pip install --upgrade pip' command.\n",
          "retcode": 0
        },
        {
          "command": [
            "/Users/fschulze/temp/tox-parallel-bug/.tox/py36/bin/python",
            "-m",
            "pip",
            "freeze"
          ],
          "output": "atomicwrites==1.3.0\nattrs==19.1.0\nmore-itertools==7.0.0\npkg==0.0.0\npluggy==0.11.0\npy==1.8.0\npytest==4.5.0\nsix==1.12.0\nwcwidth==0.1.7\n",
          "retcode": 0
        }
      ],
      "python": {
        "executable": "/Users/fschulze/temp/tox-parallel-bug/.tox/py36/bin/python",
        "name": "python",
        "version_info": [
          3,
          6,
          8,
          "final",
          0
        ],
        "version": "3.6.8 (default, Apr 30 2019, 16:51:34) \n[GCC 4.2.1 Compatible Apple LLVM 10.0.1 (clang-1001.0.46.4)]",
        "is_64": true,
        "sysplatform": "darwin"
      },
      "installpkg": {
        "md5": "c8385466301580b8f5591ae03bf8a107",
        "sha256": "b0fb48df1d530131226dd4216386a8701db7278d2532fab458558ee38e6d53c9",
        "basename": "pkg-0.0.0.zip"
      },
      "installed_packages": [
        "atomicwrites==1.3.0",
        "attrs==19.1.0",
        "more-itertools==7.0.0",
        "pkg==0.0.0",
        "pluggy==0.11.0",
        "py==1.8.0",
        "pytest==4.5.0",
        "six==1.12.0",
        "wcwidth==0.1.7"
      ],
      "test": [
        {
          "command": [
            "/Users/fschulze/temp/tox-parallel-bug/.tox/py36/bin/pytest"
          ],
          "output": "============================= test session starts ==============================\nplatform darwin -- Python 3.6.8, pytest-4.5.0, py-1.8.0, pluggy-0.11.0\ncachedir: .tox/py36/.pytest_cache\nrootdir: /Users/fschulze/temp/tox-parallel-bug\ncollected 1 item\n\ntest_parallel.py .                                                       [100%]\n\n=========================== 1 passed in 0.67 seconds ===========================\n",
          "retcode": 0
        }
      ]
    }
  }
}

With tox 3.7.0 the output contained even less:

{
  "reportversion": "1",
  "toxversion": "3.7.0",
  "platform": "darwin",
  "host": "trubel.lan",
  "testenvs": {
    "GLOB": {
      "setup": [
        {
          "command": [
            "/Users/fschulze/temp/tox-parallel-bug/bin/python3.6",
            "/Users/fschulze/temp/tox-parallel-bug/setup.py",
            "sdist",
            "--formats=zip",
            "--dist-dir",
            "/Users/fschulze/temp/tox-parallel-bug/.tox/dist"
          ],
          "output": "actionid: tox\nmsg: packaging\ncmdargs: '/Users/fschulze/temp/tox-parallel-bug/bin/python3.6 /Users/fschulze/temp/tox-parallel-bug/setup.py sdist --formats=zip --dist-dir /Users/fschulze/temp/tox-parallel-bug/.tox/dist'\n\nrunning sdist\nrunning egg_info\nwriting pkg.egg-info/PKG-INFO\nwriting dependency_links to pkg.egg-info/dependency_links.txt\nwriting top-level names to pkg.egg-info/top_level.txt\nreading manifest file 'pkg.egg-info/SOURCES.txt'\nwriting manifest file 'pkg.egg-info/SOURCES.txt'\nwarning: sdist: standard file not found: should have one of README, README.rst, README.txt, README.md\n\nrunning check\nwarning: check: missing required meta-data: url\n\nwarning: check: missing meta-data: either (author and author_email) or (maintainer and maintainer_email) must be supplied\n\ncreating pkg-0.0.0\ncreating pkg-0.0.0/pkg.egg-info\ncopying files to pkg-0.0.0...\ncopying setup.py -> pkg-0.0.0\ncopying pkg.egg-info/PKG-INFO -> pkg-0.0.0/pkg.egg-info\ncopying pkg.egg-info/SOURCES.txt -> pkg-0.0.0/pkg.egg-info\ncopying pkg.egg-info/dependency_links.txt -> pkg-0.0.0/pkg.egg-info\ncopying pkg.egg-info/top_level.txt -> pkg-0.0.0/pkg.egg-info\nWriting pkg-0.0.0/setup.cfg\ncreating .tox/dist\ncreating '.tox/dist/pkg-0.0.0.zip' and adding 'pkg-0.0.0' to it\nadding 'pkg-0.0.0'\nadding 'pkg-0.0.0/pkg.egg-info'\nadding 'pkg-0.0.0/PKG-INFO'\nadding 'pkg-0.0.0/setup.py'\nadding 'pkg-0.0.0/setup.cfg'\nadding 'pkg-0.0.0/pkg.egg-info/PKG-INFO'\nadding 'pkg-0.0.0/pkg.egg-info/SOURCES.txt'\nadding 'pkg-0.0.0/pkg.egg-info/top_level.txt'\nadding 'pkg-0.0.0/pkg.egg-info/dependency_links.txt'\nremoving 'pkg-0.0.0' (and everything under it)\n",
          "retcode": "0"
        }
      ]
    }
  }
}
@gaborbernat
Copy link
Member

@gaborbernat gaborbernat commented May 14, 2019

This is a known gap, please feel free to file a PR to solve it, thanks!

@fschulze
Copy link
Contributor Author

@fschulze fschulze commented May 22, 2019

Could someone take a look at #1309 and tell me whether I'm on the right track? If so, I will finish the PR.

@gaborbernat
Copy link
Member

@gaborbernat gaborbernat commented May 22, 2019

Commented 👍

fschulze added a commit to fschulze/tox that referenced this issue May 23, 2019
When using ``--parallel`` with ``--result-json`` the test results are now included the same way as with serial runs.
This is accomplished by generating json result output for each individual run and at the end copy the data into the main json result output.
fschulze added a commit to fschulze/tox that referenced this issue May 23, 2019
When using ``--parallel`` with ``--result-json`` the test results are now included the same way as with serial runs.
This is accomplished by generating json result output for each individual run and at the end copy the data into the main json result output.
fschulze added a commit to fschulze/tox that referenced this issue May 23, 2019
When using ``--parallel`` with ``--result-json`` the test results are now included the same way as with serial runs.
This is accomplished by generating json result output for each individual run and at the end copy the data into the main json result output.
fschulze added a commit to fschulze/tox that referenced this issue May 23, 2019
When using ``--parallel`` with ``--result-json`` the test results are now included the same way as with serial runs.
This is accomplished by generating json result output for each individual run and at the end copy the data into the main json result output.
fschulze added a commit to fschulze/tox that referenced this issue May 23, 2019
When using ``--parallel`` with ``--result-json`` the test results are now included the same way as with serial runs.
This is accomplished by generating json result output for each individual run and at the end copy the data into the main json result output.
fschulze added a commit to fschulze/tox that referenced this issue May 23, 2019
When using ``--parallel`` with ``--result-json`` the test results are now included the same way as with serial runs.
This is accomplished by generating json result output for each individual run and at the end copy the data into the main json result output.
gaborbernat added a commit to fschulze/tox that referenced this issue May 23, 2019
When using ``--parallel`` with ``--result-json`` the test results are now included the same way as with serial runs.
This is accomplished by generating json result output for each individual run and at the end copy the data into the main json result output.
gaborbernat added a commit to fschulze/tox that referenced this issue May 23, 2019
When using ``--parallel`` with ``--result-json`` the test results are now included the same way as with serial runs.
This is accomplished by generating json result output for each individual run and at the end copy the data into the main json result output.
gaborbernat added a commit that referenced this issue May 23, 2019
* Correct ``--result-json`` output with ``--parallel``. (#1295)

When using ``--parallel`` with ``--result-json`` the test results are now included the same way as with serial runs.
This is accomplished by generating json result output for each individual run and at the end copy the data into the main json result output.

* avoid duplication in code, improve coverage
@helpr helpr bot added pr-merged and removed pr-available labels May 23, 2019
@gaborbernat
Copy link
Member

@gaborbernat gaborbernat commented May 23, 2019

released via 3.12.0, thanks for your contribution
thanks

@con-f-use
Copy link

@con-f-use con-f-use commented May 1, 2020

Sorry to hijack this thread, but is there a way to put --parallel=auto and --result-json <path> in the tox.ini file, so it gets automatically set/written every time one runs tox?

@gaborbernat
Copy link
Member

@gaborbernat gaborbernat commented May 2, 2020

@con-f-use sadly at the moment there isn't 🤔

@tox-dev tox-dev locked and limited conversation to collaborators Jan 14, 2021
Sign up for free to subscribe to this conversation on GitHub. Already have an account? Sign in.
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

3 participants