New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

tox 1.9.1 ignores package versions specified in requirements.txt files #230

Closed
pytoxbot opened this Issue Sep 17, 2016 · 2 comments

Comments

Projects
None yet
1 participant
@pytoxbot

pytoxbot commented Sep 17, 2016

Hi,

It seems that tox 1.9.1 ignores package versions specified in included requirements files, and installs latest package versions instead. 1.9.0 works fine. This broke e.g. Scrapy tests.

[testenv]
deps =
    -r requirements.txt

requirements.txt:

foo == 1.0.0

Check e.g. https://travis-ci.org/scrapy/scrapy/jobs/55483601 - it has

precise installdeps: pyOpenSSL==0.13, lxml==2.3.2, Twisted==11.1.0, boto==2.2.2, Pillow<2.0, django==1.3.1, cssselect==0.9.1, zope.interface==3.6.1, mock, mitmproxy, netlib, pytest-twisted

line, but mitmproxy is specified as mitmproxy==0.10.1 in https://github.com/scrapy/scrapy/blob/master/tests/requirements.txt file.

@pytoxbot

This comment has been minimized.

pytoxbot commented Sep 17, 2016

Original comment by @hpk42

  • backout ability that --force-deps substitutes name/versions in
    requirement files due to various issues.
  • This fixes issue228, fixes issue230, fixes issue231
    which popped up with 1.9.1.
  • bump to 1.9.2 version

→ <<cset 452288d6c500>>

@pytoxbot

This comment has been minimized.

pytoxbot commented Sep 17, 2016

Original comment by isaacxi

_config.py:L405 seems to be the culprit.

Changing it locally to

name = self._replace_forced_dep(str(r).split(' ')[0], config)

works.

@pytoxbot pytoxbot closed this Sep 17, 2016

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment