rbenv.vim: Minimal rbenv support
Vim script

README.markdown

rbenv.vim

This simple plugin provides a :Rbenv command that wraps !rbenv with tab complete. It also tells recent versions of vim-ruby where your Ruby installs are located, so that it can set 'path' and 'tags' in your Ruby buffers to reflect the nearest .ruby-version file.

Bonus: projectionist.vim support for rbenv plugins.

Installation

If you don't have a preferred installation method, I recommend installing pathogen.vim, and then simply copy and paste:

cd ~/.vim/bundle
git clone git://github.com/tpope/vim-rbenv.git

FAQ

My Vim insists on using the system Ruby.

You're using zsh on OS X, aren't you? Here are some things to try:

  • Move /etc/zshenv to /etc/zshrc.
  • Set your PATH in ~/.zshenv instead of ~/.zshrc.

Self-Promotion

Like rbenv.vim? Follow the repository on GitHub and vote for it on vim.org. And if you're feeling especially charitable, follow tpope on Twitter and GitHub.

License

Copyright (c) Tim Pope. Distributed under the same terms as Vim itself. See :help license.