Ruby version not installed #2

Closed
darthdeus opened this Issue Dec 15, 2011 · 2 comments

Projects

None yet

2 participants

@darthdeus

When I run any command, i.e. :Rvm use 1.9.3, I'm getting

Ruby version not installed: :Rvm install /Users/darth/.rvm/bin/rvm: line 44: typeset: -g: invalid option^@typeset: usage: typeset [-afFirtx] [-p] name[=value] ...^@ruby-1.9.3-p0

even though 1.9.3 is installed and working correctly form terminal.

It looks like vim-rvm is using old rvm parameters.

My currently installed version:

$ rvm -v
rvm 1.10.0-pre.1 by Wayne E. Seguin (wayneeseguin@gmail.com) [https://rvm.beginrescueend.com/]
@tpope
Owner
tpope commented Jan 31, 2012

I just updated to 1.10.2, and I can't reproduce this error. If it's still an issue after updating, can you report back on what OS you're using and the output of :set shell??

@darthdeus

I had this issue on OS X Lion 10.7.2 ... however since then I reinstalled the system and reconfigured everything, so I'm not able to reproduce the issue anymore. We can probably close this.

@darthdeus darthdeus closed this Jan 31, 2012
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment