Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Fix for windows 10 VPN connection problems "parameter is incorrect" error #1051

Closed
alexmelSC opened this issue Aug 6, 2018 · 8 comments

Comments

Projects
None yet
10 participants
@alexmelSC
Copy link

commented Aug 6, 2018

Hi,

Solved this issue myself but saw no mention on here.

I recently moved to a new server where I have Algo VPN but kept getting a weird error "parameter is incorrect" when connection to it.

SOLUTION:

If you install the Windows 10 ps1 file (as noted in the installation instructions) and when you try to connect is says "parameter is incorrect" then so the following:

  1. Clear the Networking caches

Run windows cmd window (click windows start menu, type 'cmd', right click on 'Command Prompt' and select "Run as Administrator").

type command below
netsh int ip reset

then type
netsh int ipv6 reset

then type
netsh winsock reset

Restart your computer.

  1. Reset Device Manager adaptors

    Open Device Manager
    Find Network Adapters
    Uninstall WAN Miniport drivers (IKEv2, IP, IPv6, etc)
    Click Action > Scan for hardware changes
    The adapters you just uninstalled should come back

The VPN connection then works.

Hope this helps someone.

@nerrons

This comment has been minimized.

Copy link

commented Sep 18, 2018

Worked like a charm. Thank you dguido.

@saadat99

This comment has been minimized.

Copy link

commented Oct 14, 2018

It works but is there an easier fix? I don't like to do this on all my machines
What causes this issue?

@trottit

This comment has been minimized.

Copy link

commented Feb 1, 2019

Parameter Incorrect is a problem I have and followed the fix instructions.Still getting the same message and starting to come to the conclusion that there is a corrupt file on the system.Any ideas from any one who has been tormented from this would be greatly appreciated. In the meantime good luck and keep up the brilliant work.Kind regards to you all.

@soulmercy

This comment has been minimized.

Copy link

commented Feb 11, 2019

Parameter Incorrect is a problem I have and followed the fix instructions.Still getting the same message and starting to come to the conclusion that there is a corrupt file on the system.Any ideas from any one who has been tormented from this would be greatly appreciated. In the meantime good luck and keep up the brilliant work.Kind regards to you all.

First problem I meet is modem problem. I first click the "reset network" in Setting -> Network and then restart PC, but problem turn to same with you(Parameter Incorrect). Then I tried this solution, after 1st step, the problem still occur. But after 2nd step the problem finally resolved.

@minblock

This comment has been minimized.

Copy link

commented Feb 17, 2019

It truly does

@qianniancc

This comment has been minimized.

Copy link

commented Mar 29, 2019

This is useful to me, thank you.

@teadrinkingbear

This comment has been minimized.

Copy link

commented Apr 22, 2019

AWESOME! Just signed up to thank you! This was so struggling as malfunctioning VPN is equivalent to death in China. You are my savior and make my day.

@kylekoren

This comment has been minimized.

Copy link

commented Apr 26, 2019

You are a godsend! Thank you so much!

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.