New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Explicitly require Python>=3.6 when using CLI #1331

Merged
merged 2 commits into from Jan 9, 2019

Conversation

Projects
None yet
1 participant
@disconnect3d
Copy link
Contributor

disconnect3d commented Jan 9, 2019

We have this in setup.py python_requires but it doesn't work with old pip versions and we get reports that Manticore throws a SyntaxError (on a f-string literal :/).


This change is Reviewable

Require Python>=3.6
We have this in setup.py python_requires but it doesn't work with old
pip versions and we get reports that Manticore throws a SyntaxError (on a
f-string literal :/).

@disconnect3d disconnect3d changed the title Require Python>=3.6 Explicitly require Python>=3.6 when using CLI Jan 9, 2019

@disconnect3d disconnect3d merged commit 0814222 into master Jan 9, 2019

4 of 5 checks passed

codeclimate 2 issues to fix
Details
codeclimate/total-coverage 71%
Details
continuous-integration/travis-ci/pr The Travis CI build passed
Details
continuous-integration/travis-ci/push The Travis CI build passed
Details
license/cla Contributor License Agreement is signed.
Details

@disconnect3d disconnect3d deleted the require-py-3.6 branch Jan 9, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment