Skip to content
Permalink
Browse files

replace babel-polyfill based upon warning to use core-js and regenrat…

  • Loading branch information...
chrisgilmerproj committed Jun 7, 2019
1 parent c11964b commit a1f47ae472eefe05a85f052d6054f7d0c2d648ca
Showing with 9 additions and 16 deletions.
  1. +2 −1 package.json
  2. +2 −1 src/index.js
  3. +5 −14 yarn.lock
@@ -4,9 +4,9 @@
"@fortawesome/fontawesome": "^1.1.6",
"@fortawesome/fontawesome-free-solid": "^5.0.11",
"@fortawesome/react-fontawesome": "^0.0.19",
"babel-polyfill": "^6.26.0",
"bytes": "^3.0.0",
"classnames": "^2.2.5",
"core-js": "^3.1.3",
"enzyme": "^3.2.0",
"enzyme-adapter-react-16": "^1.1.1",
"eslint-plugin-no-only-tests": "^2.3.0",
@@ -56,6 +56,7 @@
"redux-form": "^7.2.1",
"redux-mock-store": "1.5.1",
"redux-thunk": "^2.2.0",
"regenerator-runtime": "^0.13.2",
"reselect": "^4.0.0",
"selenium-webdriver": "^3.6.0",
"swagger-client": "^3.4.6",
@@ -1,6 +1,7 @@
// This must be the first line in src/index.js
import 'react-app-polyfill/ie11';
import 'babel-polyfill'; //todo: is this still needed?
import 'core-js/stable';
import 'regenerator-runtime/runtime';
import React from 'react';
import ReactDOM from 'react-dom';
import 'uswds';
@@ -2449,15 +2449,6 @@ babel-plugin-transform-react-remove-prop-types@0.4.24:
resolved "https://registry.yarnpkg.com/babel-plugin-transform-react-remove-prop-types/-/babel-plugin-transform-react-remove-prop-types-0.4.24.tgz#f2edaf9b4c6a5fbe5c1d678bfb531078c1555f3a"
integrity sha512-eqj0hVcJUR57/Ug2zE1Yswsw4LhuqqHhD+8v120T1cl3kjg76QwtyBrdIk4WVwK+lAhBJVYCd/v+4nc4y+8JsA==

babel-polyfill@^6.26.0:
version "6.26.0"
resolved "https://registry.yarnpkg.com/babel-polyfill/-/babel-polyfill-6.26.0.tgz#379937abc67d7895970adc621f284cd966cf2153"
integrity sha1-N5k3q8Z9eJWXCtxiHyhM2WbPIVM=
dependencies:
babel-runtime "^6.26.0"
core-js "^2.5.0"
regenerator-runtime "^0.10.5"

babel-preset-jest@^24.6.0:
version "24.6.0"
resolved "https://registry.yarnpkg.com/babel-preset-jest/-/babel-preset-jest-24.6.0.tgz#66f06136eefce87797539c0d63f1769cc3915984"
@@ -3570,6 +3561,11 @@ core-js@^2.4.0, core-js@^2.5.0, core-js@^2.5.3:
resolved "https://registry.yarnpkg.com/core-js/-/core-js-2.6.9.tgz#6b4b214620c834152e179323727fc19741b084f2"
integrity sha512-HOpZf6eXmnl7la+cUdMnLvUxKNqLUzJvgIziQ0DiF3JwSImNphIqdGqzj6hIKyX04MmV0poclQ7+wjWvxQyR2A==

core-js@^3.1.3:
version "3.1.3"
resolved "https://registry.yarnpkg.com/core-js/-/core-js-3.1.3.tgz#95700bca5f248f5f78c0ec63e784eca663ec4138"
integrity sha512-PWZ+ZfuaKf178BIAg+CRsljwjIMRV8MY00CbZczkR6Zk5LfkSkjGoaab3+bqRQWVITNZxQB7TFYz+CFcyuamvA==

core-util-is@1.0.2, core-util-is@~1.0.0:
version "1.0.2"
resolved "https://registry.yarnpkg.com/core-util-is/-/core-util-is-1.0.2.tgz#b5fd54220aa2bc5ab57aab7140c940754503c1a7"
@@ -11141,11 +11137,6 @@ regenerator-runtime@0.13.2, regenerator-runtime@^0.13.2:
resolved "https://registry.yarnpkg.com/regenerator-runtime/-/regenerator-runtime-0.13.2.tgz#32e59c9a6fb9b1a4aff09b4930ca2d4477343447"
integrity sha512-S/TQAZJO+D3m9xeN1WTI8dLKBBiRgXBlTJvbWjCThHWZj9EvHK70Ff50/tYj2J/fvBY6JtFVwRuazHN2E7M9BA==

regenerator-runtime@^0.10.5:
version "0.10.5"
resolved "https://registry.yarnpkg.com/regenerator-runtime/-/regenerator-runtime-0.10.5.tgz#336c3efc1220adcedda2c9fab67b5a7955a33658"
integrity sha1-M2w+/BIgrc7dosn6tntaeVWjNlg=

regenerator-runtime@^0.11.0, regenerator-runtime@^0.11.1:
version "0.11.1"
resolved "https://registry.yarnpkg.com/regenerator-runtime/-/regenerator-runtime-0.11.1.tgz#be05ad7f9bf7d22e056f9726cee5017fbf19e2e9"

0 comments on commit a1f47ae

Please sign in to comment.
You can’t perform that action at this time.