Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

pootle_fs git install #6759

Open
jauzzz opened this issue Sep 20, 2017 · 7 comments
Open

pootle_fs git install #6759

jauzzz opened this issue Sep 20, 2017 · 7 comments

Comments

@jauzzz
Copy link

@jauzzz jauzzz commented Sep 20, 2017

Steps to reproduce:

pip install --process-dependency-links Pootle[git]

Results (Expected/Actual):

Could not find a version that satisfies the requirement pootle-fs-git==0.0.1; extra == "git" (from Pootle[git]) (from versions: )
No matching distribution found for pootle-fs-git==0.0.1; extra == "git" (from Pootle[git])

Environment (i.e. 'pootle --version', DB, OS, Browser):

ubuntu 16.04
Pootle 2.9.0rc1 (Django 1.10.8, Translate Toolkit 2.2.5)

I can not install the pootle-git plugin in mac and ubuntu.What is the problem?


And another problem.

when i use update_stores, it prompt that it was deprecated, and use pootle fs.

So I did. Here is result.

pootle fs

So, it should be add my file from disk, but nothing happen, or just my misunderstand for the command.

@jauzzz jauzzz closed this Sep 21, 2017
@jauzzz jauzzz reopened this Sep 21, 2017
@phlax

This comment has been minimized.

Copy link
Member

@phlax phlax commented Sep 21, 2017

re the second problem @jauzzz - did you do pootle fs fetch cms before attempting to add the files ?

@jauzzz

This comment has been minimized.

Copy link
Author

@jauzzz jauzzz commented Sep 21, 2017

@phlax Yes, I also found that now I can run Pootle smoothly.

Thanks for your help and Pootle.

But still have a few questions to ask you for advice.

The reason is this:
The boss does not want to each time the translation work is connected to the server, only allow me to configure Pootle when deploying.

and so:

  1. There are ways to do as transifex, the machine can use the command line to upload to Pootle, from Pootle pull translation files?

  2. Or there are some ways to make the hard disk and pootle translation files automatically consistent, that is, when I add a translation in Pootle, can automatically push to the server local, the same, when the project's local file changes (intends to use FTP Upload), Pootle can also automatically pull the latest file.

  3. Or write the Web interface to complete init, sync, pull and push?

@phlax

This comment has been minimized.

Copy link
Member

@phlax phlax commented Sep 21, 2017

not sure i follow exactly @jauzzz - can you jump onto https://gitter.im/translate/pootle and we can discuss

@jauzzz

This comment has been minimized.

Copy link
Author

@jauzzz jauzzz commented Sep 21, 2017

@phlax yuh

@boite

This comment has been minimized.

Copy link
Contributor

@boite boite commented Oct 3, 2017

I'm also unable to install Pootle's git extra:-

(env) $ pip install --pre --process-dependency-links Pootle[git]==2.9.0rc1
...
Collecting pootle-fs-git==0.0.1; extra == "git" (from Pootle[git]==2.9.0rc1)
  Could not find a version that satisfies the requirement pootle-fs-git==0.0.1; extra == "git" (from Pootle[git]==2.9.0rc1) (from versions: )
No matching distribution found for pootle-fs-git==0.0.1; extra == "git" (from Pootle[git]==2.9.0rc1)

I suppose this is because there are no releases for translate/pootle_fs_git, but this installation method is what's in the docs:-

http://docs.translatehouse.org/projects/pootle/en/latest/features/integrate_with_vcs.html#install-pootle-fs-plugins-for-vcs

http://docs.translatehouse.org/projects/pootle/en/stable-2.8.x/features/pootle_fs_install_plugins.html#install-the-pootle-fs-plugins

What is the correct way to install the git plugin?

@boite

This comment has been minimized.

Copy link
Contributor

@boite boite commented Oct 3, 2017

This does work:-

(env) $ pip install -e git+https://github.com/translate/pootle_fs_git#egg=pootle-fs-git-0.0.1

So I wonder if there's something wrong with pootle.setup.parse_requirements.

@qguv

This comment has been minimized.

Copy link

@qguv qguv commented Jul 31, 2019

This is still happening—are there any plans to fix the package or at least the docs?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
4 participants
You can’t perform that action at this time.