Skip to content
tranSMART is a knowledge management platform that enables scientists to develop and refine research hypotheses by investigating correlations between genetic and phenotypic data, and assessing their analytical results in the context of published literature and other work.
JavaScript HTML Groovy CSS Java PLSQL Other
Latest commit f92eee2 May 26, 2016 @Terry-Weymouth Terry-Weymouth Merge pull request #180 from baroleg/baroleg_master
Data Export progress display bug
Failed to load latest commit information.
demo Make demo scripts generic Apr 14, 2016
grails-app Merge pull request #180 from baroleg/baroleg_master May 26, 2016
lib
licenses initial commit from GPL09 SVN Feb 27, 2012
scripts Cleaning Janssen Headers Nov 3, 2014
src
test Add copyright headers Apr 18, 2016
web-app
.gitattributes
.gitignore Template alignement for Grails 2.3.11 Sep 26, 2014
.travis.BuildConfig.groovy Try to fix travis Sep 3, 2014
.travis.yml Fix test & travis build when rest-api is inlined Mar 6, 2015
LICENSE.TXT
NOTICE.TXT updated for GPL 1.0 RC1 Apr 24, 2012
README.md Restored README.md from e85242d - latest version that I could find. D… Nov 19, 2014
application.properties
h2_init.sql
pom_sonar.xml Automatic code reformat Oct 9, 2014

README.md

transmartApp

tranSMART is a knowledge management platform that enables scientists to develop and refine research hypotheses by investigating correlations between genetic and phenotypic data, and assessing their analytical results in the context of published literature and other work.

Installation

Some pre-requisites are required in order to run tranSMART. For development, a copy of grails is needed in order to run the application. For production or evaluation purposes, it is sufficient to download a pre-build WAR file, for instance a snapshot from the The Hyveʼs or tranSMART Foundationʼs CI/build servers, for snapshots of The Hyveʼs or tranSMART Foundationʼs GitHub repositories, respectively. In order to run the WAR, an application server is required. The only supported one is Tomcat, either from the 6.x or 7.x line, though it will most likely work on others.

In addition, a PostgreSQL database installed with the proper schema and data is required. As of this moment, The Hyveʼs development branches require this to be propared with the transmart-data repository. This project also handles the required configuration, running the Solr instances and, for development purposes, running an R server and installing sample data.

For details on how to install the tranSMART Foundationʼs versions, refer to their wiki.

Something went wrong with that request. Please try again.