New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Failed test 'Pod coverage on File::LsColor' #2

Closed
eserte opened this Issue Dec 6, 2018 · 2 comments

Comments

Projects
None yet
2 participants
@eserte
Copy link

eserte commented Dec 6, 2018

The pod coverage test is failing:

#   Failed test 'Pod coverage on File::LsColor'
#   at /usr/perl5.16.3t/lib/site_perl/5.16.3/Test/Pod/Coverage.pm line 133.
# Coverage for File::LsColor is 85.7%, with 1 naked subroutine:
# 	ls_color_lookup
# Looks like you failed 1 test of 1.
t/02-pod-coverage.t .. 
Dubious, test returned 1 (wstat 256, 0x100)
Failed 1/1 subtests 

Additionally the synopsis test also fails:

#   Failed test 'lib/File/LsColor.pm'
#   at /usr/perl5.16.3t/lib/site_perl/5.16.3/Test/Synopsis.pm line 24.
# syntax error at lib/File/LsColor.pm line 348, near "...
# 
# # returns a hashref with all defined filetypes and their attributes
# my "
# Global symbol "$ls_colors" requires explicit package name at lib/File/LsColor.pm line 348.
# Looks like you failed 1 test of 1.
t/021-synopsis.t ..... 
Dubious, test returned 1 (wstat 256, 0x100)
Failed 1/1 subtests 
@eserte

This comment has been minimized.

Copy link

eserte commented Jan 16, 2019

Same problem with File-LsColor-0.194, it seems.

@trapd00r

This comment has been minimized.

Copy link
Owner

trapd00r commented Jan 16, 2019

Thank you, it's fixed now.

@trapd00r trapd00r closed this Jan 16, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment