Permalink
Browse files

Wretched compatability with Ruby 1.9...

  • Loading branch information...
1 parent 94d4d27 commit 1fa8cc36d2fb2a1999370d7fd61f1240727efbe6 @MGPalmer MGPalmer committed Feb 9, 2011
Showing with 8 additions and 0 deletions.
  1. +5 −0 README.rdoc
  2. +3 −0 lib/masterplan.rb
View
@@ -156,6 +156,11 @@ Or, install latest version from Github with bundler by adding this to your Gemfi
gem 'masterplan', :git => 'git://github.com/traveliq/masterplan.git'
+== Dependencies
+
+You'll need ActiveSupport, but that should be handled automatically.
+Under Ruby 1.9.x, however, you need the test-unit gem. It works for us with test-unit 1.2.3.
+
== Authors
Martin Tepper (monogreen.de), Holger Pillmann (holger.pillmann@gmail.com), Dr. Florian Odronitz (odo@mac.com)
View
@@ -3,6 +3,9 @@
if ActiveSupport::VERSION::STRING >= "3.0.0"
require 'active_support/core_ext'
end
+if RUBY_VERSION > '1.9'
+ gem 'test-unit'
+end
require 'test/unit/assertions'
require 'masterplan'
require 'masterplan/rule'

0 comments on commit 1fa8cc3

Please sign in to comment.