Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Relax the R >= 3.5 requirement #11

Closed
gaborcsardi opened this issue Jul 10, 2019 · 4 comments
Closed

Relax the R >= 3.5 requirement #11

gaborcsardi opened this issue Jul 10, 2019 · 4 comments

Comments

@gaborcsardi
Copy link

@gaborcsardi gaborcsardi commented Jul 10, 2019

What would it take to support R >= 3.2?

@traversc

This comment has been minimized.

Copy link
Owner

@traversc traversc commented Jul 10, 2019

Just deleting the alt-rep stuff. I'm using it because I think the string cache is unnecessarily slow, but someone else pointed out that it can blow up memory.

@gaborcsardi

This comment has been minimized.

Copy link
Author

@gaborcsardi gaborcsardi commented Jul 10, 2019

@traversc

This comment has been minimized.

Copy link
Owner

@traversc traversc commented Jul 15, 2019

Hi Gabor, I updated the github version so that it works with R < 3.5. Instead of having two different versions, I used preprocessor macros to comment out alt-rep stuff if it detects R < 3.5.

Tested it out with R 3.4 on windows.

@gaborcsardi

This comment has been minimized.

Copy link
Author

@gaborcsardi gaborcsardi commented Jul 15, 2019

Thanks!

@traversc traversc closed this Jul 22, 2019
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Projects
None yet
Linked pull requests

Successfully merging a pull request may close this issue.

None yet
2 participants
You can’t perform that action at this time.