New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Documentation that uses encrypt commands is a bit outdated #1942

Closed
tadeboro opened this Issue Jul 21, 2018 · 5 comments

Comments

Projects
None yet
3 participants
@tadeboro
Copy link

tadeboro commented Jul 21, 2018

I just registered new open source ruby project on travis-ci.com with the purpose of automating gem releases. I followed the instructions in the RubyGems Deployment document and the deploy failed.

It took me quite a while to notice that travis encrypt command uses travis-ci.org endpoint by default and that I need to add --pro command line flag in order to direct it to the proper endpoint.

I am willing to help fix the docs by describing the procedures for both endpoints, but before I start, I would like to get some feedback on that idea. Or should we just wait for the migration to end and then the tools will use the right endpoint anyhow?

@tadeboro

This comment has been minimized.

Copy link

tadeboro commented Jul 21, 2018

I just found a pull request that already tries to solve this issue: #1922

@Hanse00

This comment has been minimized.

Copy link

Hanse00 commented Sep 10, 2018

Came to report the same, the PR you linked to returns a 404. Perhaps it needs to be updated after all?

@tadeboro

This comment has been minimized.

Copy link

tadeboro commented Sep 10, 2018

@Hanse00 It seems that pull request in question has been made private (I just discovered this by accidentally hoovering over the PR link). Maybe travis people are already on it and they just forgot to communicate this to the outside?

@plaindocs

This comment has been minimized.

Copy link
Contributor

plaindocs commented Sep 24, 2018

Hi Folks,

Thanks for noticing this. I'm pretty sure the relevant PR is this one #1961

If you've not updated the travis gem it'll still use old defaults though.

@stale

This comment has been minimized.

Copy link

stale bot commented Dec 23, 2018

Thanks for contributing to this issue. As it has been 90 days since the last activity, we are automatically closing the issue. This is often because the request was already solved in some way and it just wasn't updated or it's no longer applicable. If that's not the case, please do feel free to either reopen this issue or open a new one. We'll gladly take a look again! You can read more here: https://blog.travis-ci.com/2018-03-09-closing-old-issues

@stale stale bot added the stale label Dec 23, 2018

@stale stale bot closed this Dec 24, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment