New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Firebase hosting deployment currently errors, need to release PR #883 #890

Closed
ludwigschubert opened this Issue Oct 25, 2018 · 8 comments

Comments

Projects
None yet
3 participants
@ludwigschubert

ludwigschubert commented Oct 25, 2018

Firebase deployments currently error with this error message:

HTTP Error: 410, Unknown Error

This Stack Overflow post cites the firebase user Slack workspace (not linkable; yay modern internet!):

If you are receiving a 410 error, you will likely need to update your cli version (firebase-tools). Updating to the latest version should fix it. You will need to upgrade your CLI version to at least 4.1.0 (>= 5.1.1 is recommended).

PR #883 seems to have fixed this by upgrading firebase-tools to major version 5, but travis production is currently on an older release of the dpl package that does not include this patch.

This ticket only wants to bring attention to that fact, and that a new release soon would be appreciated.
(Alternatively a way to specify which version of dpl a travis build uses may be helpful in general?)

@BanzaiMan

This comment has been minimized.

Member

BanzaiMan commented Oct 25, 2018

Sorry for the troubles, and thanks for bringing this to our attention. I was hoping to get a few more PRs tested (especially Elastic Beanstalk ones) before the 1.10.4 release, but I think I'll move up the release earlier. Maybe Monday.

Again, thank you for taking time to open the issue.

@BanzaiMan

This comment has been minimized.

Member

BanzaiMan commented Oct 26, 2018

Oh, if you need the fix right now, try:

deploy:
  provider: firebase
  edge: true# rest

jakawell added a commit to jakawell/dpsplus that referenced this issue Oct 26, 2018

Travis Firebase error workaround
Attempt at temporary workaround for Travis Firebase integration error (travis-ci/dpl#890) by switching to prerelease Firebase provider. Will want to revert this after Travis is updated (probably Monday).

canguruhh added a commit to mvs-org/lightwallet that referenced this issue Oct 28, 2018

jerr0328 added a commit to jerr0328/jerr0328.github.io that referenced this issue Oct 29, 2018

@BanzaiMan

This comment has been minimized.

Member

BanzaiMan commented Oct 29, 2018

1.10.4 has been released.

@BanzaiMan BanzaiMan closed this Oct 29, 2018

@Durisvk

This comment has been minimized.

Durisvk commented Oct 29, 2018

@BanzaiMan was it also resolved for travis-ci.com? or just travis-ci.org?

@BanzaiMan

This comment has been minimized.

Member

BanzaiMan commented Oct 29, 2018

@Durisvk The released version is available for both. Are you seeing problems? If so, please point to the build log showing the problem.

@ludwigschubert

This comment has been minimized.

ludwigschubert commented Oct 29, 2018

@BanzaiMan; update works for us! Thanks for the edge: true workaround and fast turnarouond in general! :-)

@BanzaiMan

This comment has been minimized.

Member

BanzaiMan commented Oct 29, 2018

@ludwigschubert Great to hear that it's working for you. Again, thank you for alerting us, and for your patience.

@Durisvk

This comment has been minimized.

Durisvk commented Oct 30, 2018

@BanzaiMan it’s ok now, thank you :)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment