Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
Browse files

Specify oa-oauth version

  • Loading branch information...
commit 8e5f685113ef35619d6553e7e0a944c353966dc7 1 parent b4a6023
Erik Michaels-Ober sferik authored
Showing with 41 additions and 47 deletions.
  1. +29 −33 Gemfile
  2. +12 −14 Gemfile.lock
62 Gemfile
View
@@ -1,45 +1,41 @@
-source :rubygems
-
-gem 'rails', '~> 3.0.5'
-gem 'SystemTimer', '~> 1.2.2', :platforms => ['ruby_18']
-gem 'yajl-ruby', '~> 0.8.1'
-gem "oa-oauth", :require => "omniauth/oauth"
-gem "devise", '~> 1.2.rc'
-gem 'pusher', '~> 0.8.0'
-gem 'unobtrusive_flash', '~> 0.0.2'
-gem 'hoptoad_notifier', '~> 2.4.6'
-gem 'refraction', '~> 0.2.0'
-gem 'resque', '~> 1.13.0'
-gem 'resque-meta', '~> 1.0.3'
-gem 'em-websocket', '~> 0.2.0'
-gem 'travis-ci-em-pusher', '~> 0.1.1'
-gem 'compass', '~> 0.10.6'
-gem 'jammit'
-gem 'em-http-request'
+source 'http://rubygems.org'
+
+gem 'rails', '~> 3.0.5'
+
+gem 'SystemTimer', '~> 1.2.2', :platforms => ['ruby_18']
+gem 'compass', '~> 0.10.6'
+gem 'devise', '~> 1.2.rc'
+gem 'em-http-request', '~> 0.3.0'
+gem 'em-websocket', '~> 0.2.0'
+gem 'hoptoad_notifier', '~> 2.4.6'
+gem 'jammit', '~> 0.6.0'
+gem 'oa-oauth', '~> 0.2.1', :require => 'omniauth/oauth'
+gem 'pusher', '~> 0.8.0'
+gem 'refraction', '~> 0.2.0'
+gem 'resque', '~> 1.13.0'
+gem 'resque-meta', '~> 1.0.3'
+gem 'travis-ci-em-pusher', '~> 0.1.1'
+gem 'unobtrusive_flash', '~> 0.0.2'
+gem 'yajl-ruby', '~> 0.8.1'
group :development do
- gem 'sqlite3-ruby', :require => 'sqlite3'
+ gem 'sqlite3'
end
group :test do
- gem 'cucumber-rails', :git => 'git://github.com/aslakhellesoy/cucumber-rails.git'
- gem 'capybara'
# gem 'steam', :path => '~/Development/projects/steam'
# gem 'locator', :path => '~/Development/projects/locator'
-
- gem 'test_declarative'
- gem 'ruby-debug', :platforms => ['ruby_18']
- gem 'ruby-debug19', :platforms => ['ruby_19']
-
- gem 'minitest', '~> 2.0.2', :platforms => ['ruby_18']
- gem 'minitest_tu_shim', '~> 1.3.2', :platforms => ['ruby_18']
-
- gem 'mocha'
+ # gem 'webmock'
+ gem 'capybara'
+ gem 'cucumber-rails', :git => 'git://github.com/aslakhellesoy/cucumber-rails.git'
gem 'database_cleaner'
gem 'factory_girl_rails', :git => 'git://github.com/thoughtbot/factory_girl_rails.git'
- # gem 'webmock'
gem 'fakeweb'
-
+ gem 'minitest', '~> 2.0.2', :platforms => ['ruby_18']
+ gem 'minitest_tu_shim', '~> 1.3.2', :platforms => ['ruby_18']
+ gem 'mocha'
+ gem 'ruby-debug', :platforms => ['ruby_18']
+ gem 'ruby-debug19', :platforms => ['ruby_19']
+ gem 'test_declarative'
gem 'web-socket-ruby'
end
-
26 Gemfile.lock
View
@@ -94,10 +94,10 @@ GEM
eventmachine (0.12.10)
factory_girl (2.0.0.beta2)
fakeweb (1.3.0)
- faraday (0.5.7)
+ faraday (0.6.0)
addressable (~> 2.2.4)
multipart-post (~> 1.1.0)
- rack (>= 1.1.0, < 2)
+ rack (< 2, >= 1.1.0)
ffi (0.6.3)
rake (>= 0.8.7)
gherkin (2.3.4)
@@ -128,17 +128,17 @@ GEM
multi_json (0.0.5)
multipart-post (1.1.0)
nokogiri (1.4.4)
- oa-core (0.2.0)
+ oa-core (0.2.1)
rack (~> 1.1)
- oa-oauth (0.2.0)
+ oa-oauth (0.2.1)
multi_json (~> 0.0.2)
nokogiri (~> 1.4.2)
- oa-core (= 0.2.0)
+ oa-core (= 0.2.1)
oauth (~> 0.4.0)
- oauth2 (~> 0.1.1)
+ oauth2 (~> 0.2.0)
oauth (0.4.4)
- oauth2 (0.1.1)
- faraday (~> 0.5.0)
+ oauth2 (0.2.0)
+ faraday (~> 0.6.0)
multi_json (~> 0.0.4)
orm_adapter (0.0.4)
polyglot (0.3.1)
@@ -205,8 +205,6 @@ GEM
rack (~> 1.1)
tilt (>= 1.2.2, < 2.0)
sqlite3 (1.3.3)
- sqlite3-ruby (1.3.3)
- sqlite3 (>= 1.3.3)
term-ansicolor (1.0.5)
test_declarative (0.0.5)
thor (0.14.6)
@@ -239,16 +237,16 @@ DEPENDENCIES
cucumber-rails!
database_cleaner
devise (~> 1.2.rc)
- em-http-request
+ em-http-request (~> 0.3.0)
em-websocket (~> 0.2.0)
factory_girl_rails!
fakeweb
hoptoad_notifier (~> 2.4.6)
- jammit
+ jammit (~> 0.6.0)
minitest (~> 2.0.2)
minitest_tu_shim (~> 1.3.2)
mocha
- oa-oauth
+ oa-oauth (~> 0.2.1)
pusher (~> 0.8.0)
rails (~> 3.0.5)
refraction (~> 0.2.0)
@@ -256,7 +254,7 @@ DEPENDENCIES
resque-meta (~> 1.0.3)
ruby-debug
ruby-debug19
- sqlite3-ruby
+ sqlite3
test_declarative
travis-ci-em-pusher (~> 0.1.1)
unobtrusive_flash (~> 0.0.2)
Please sign in to comment.
Something went wrong with that request. Please try again.