New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Restarted build's status is set according to previous build number not previous build status #1832

Closed
Seldaek opened this Issue Jan 6, 2014 · 1 comment

Comments

Projects
None yet
3 participants
@Seldaek

Seldaek commented Jan 6, 2014

To explain more clearly here is a timeline:

Build state is passing
Build #10 success -> no email sent since it was passing already
Build #11 fails -> email is sent about the failure
Build #12 succeeds -> email is sent that build got fixed
Build #12 is restarted, still succeeds -> email is sent that build got fixed

The last email IMO should not be sent, much like Build #10 triggered no email, since the previous build (the first #12) passed.

This may be by design, but this behavior is sometimes a bit of a pain when working with http://www.rust-ci.org since it restarts builds every time a new rust snapshot is out.

@roidrage roidrage added the bugsquash label Jun 10, 2014

@BanzaiMan

This comment has been minimized.

Show comment
Hide comment
@BanzaiMan

BanzaiMan Jun 17, 2014

Member

I think this is a duplicate of #483. Let us know if you disagree.

Member

BanzaiMan commented Jun 17, 2014

I think this is a duplicate of #483. Let us know if you disagree.

@BanzaiMan BanzaiMan closed this Jun 17, 2014

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment