Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

Python's SMTP DebuggingServer works until it doesn't. #525

Closed
tvaughan opened this Issue May 3, 2012 · 3 comments

Comments

Projects
None yet
3 participants

tvaughan commented May 3, 2012

I use nose, and have it start Python's smtp DebuggingServer before any tests are run. For example:

https://github.com/rentalita/django-collector/blob/master/src/python/collector/tests/__init__.py

This has never failed me on the command-line. I just set this up on Travis (awesome!), and this works randomly. For example:

http://travis-ci.org/#!/rentalita/django-collector/jobs/1240125
http://travis-ci.org/#!/rentalita/django-collector/jobs/1240126

Sometimes it's Python 2.6 that fails, othertimes it's 2.7. EMAIL_HOST and EMAIL_PORT are localhost and 1025 respectively.

Is there some other way I should do this on Travis? Thanks.

tvaughan commented May 4, 2012

I thought this could be because the same port number is used in both cases. I switched to a random port number, and that helps, but this still fails in the same way, just less frequently now. Thanks.

Contributor

henrikhodne commented Dec 31, 2012

Are you still seeing this issue?

Owner

joshk commented Sep 28, 2013

I am closing this issue for now as we haven't had any updates. Please open a new ticket if you are still experiencing issues. Thanks a bundle, Josh.

@joshk joshk closed this Sep 28, 2013

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment