New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

.NET Core 2.0.0 fails to install on osx: Cannot install on volume / because it is disabled. #8617

Closed
tmds opened this Issue Oct 19, 2017 · 2 comments

Comments

Projects
None yet
2 participants
@tmds

tmds commented Oct 19, 2017

language: csharp
mono: none
dotnet: 2.0.0

os:
  - linux
  - osx

sudo: required
dist: trusty

On osx fails to install .NET Core: : 0.86sinstaller: Cannot install on volume / because it is disabled.

Updating Homebrew...
Error: openssl 1.0.2j is already installed
To upgrade to 1.0.2l, run `brew upgrade openssl`
11.73s$ wget --retry-connrefused --waitretry=1 -O /tmp/dotnet.pkg https://dotnetcli.azureedge.net/dotnet/Sdk/2.0.0/dotnet-sdk-2.0.0-osx-x64.pkg
--2017-10-19 18:08:38--  https://dotnetcli.azureedge.net/dotnet/Sdk/2.0.0/dotnet-sdk-2.0.0-osx-x64.pkg
Resolving dotnetcli.azureedge.net... 72.21.81.200, 2606:2800:11f:17a5:191a:18d5:537:22f9
Connecting to dotnetcli.azureedge.net|72.21.81.200|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 139976149 (133M) [application/octet-stream]
Saving to: ‘/tmp/dotnet.pkg’
/tmp/dotnet.pkg     100%[===================>] 133.49M  12.6MB/s    in 11s     
2017-10-19 18:08:50 (12.3 MB/s) - ‘/tmp/dotnet.pkg’ saved [139976149/139976149]
0.86sinstaller: Cannot install on volume / because it is disabled.
installer: OS X version 10.12 or later is required.
The command "sudo installer -package "/tmp/dotnet.pkg" -target "/" -verboseR" failed and exited with 1 during .

cc @Joshua-Anderson @akoeplinger @nterry

@akoeplinger

This comment has been minimized.

Show comment
Hide comment
@akoeplinger

akoeplinger Oct 19, 2017

@tmds .NET Core 2.0 requires OSX 10.12 or later and Travis by default uses OSX 10.11. You can use a newer OSX by adding e.g. osx_image: xcode8.1 to .travis.yml: https://docs.travis-ci.com/user/reference/osx/#OS-X-Version

(the check which should prevent this case wasn't updated for .NET Core 2.0 so it still only checks for .NET Core 1.x requirements).

akoeplinger commented Oct 19, 2017

@tmds .NET Core 2.0 requires OSX 10.12 or later and Travis by default uses OSX 10.11. You can use a newer OSX by adding e.g. osx_image: xcode8.1 to .travis.yml: https://docs.travis-ci.com/user/reference/osx/#OS-X-Version

(the check which should prevent this case wasn't updated for .NET Core 2.0 so it still only checks for .NET Core 1.x requirements).

@tmds

This comment has been minimized.

Show comment
Hide comment
@tmds

tmds Oct 19, 2017

Thank you @akoeplinger ! I will give that a try and close this issue if it is working well.

tmds commented Oct 19, 2017

Thank you @akoeplinger ! I will give that a try and close this issue if it is working well.

akoeplinger added a commit to akoeplinger/travis-build that referenced this issue Oct 19, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment