New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Cannot clone METADATA.jl with Julia v0.5 on Linux #9264

Closed
galenlynch opened this Issue Feb 24, 2018 · 6 comments

Comments

Projects
None yet
6 participants
@galenlynch

galenlynch commented Feb 24, 2018

@tkelman, @ninjin, @staticfloat, @simonbyrne

I am trying to build my package with TravisCI for the first time in many months, and am no longer able to do so on Julia v0.5. If I go to builds that previously passed and try to build them, I get this error:

ERROR: GitError(Code:ERROR, Class:Net, SSL error: error:1407742E:SSL routines:SSL23_GET_SERVER_HELLO:tlsv1 alert protocol version)

An example of this error can be found here.

I do not get this error in v0.6 linux, or on v0.5 mac.

@simonbyrne

This comment has been minimized.

Show comment
Hide comment
@simonbyrne

simonbyrne Feb 25, 2018

@aviks Is this related to the problem you were having?

simonbyrne commented Feb 25, 2018

@aviks Is this related to the problem you were having?

@staticfloat

This comment has been minimized.

Show comment
Hide comment
@staticfloat

staticfloat Feb 25, 2018

This is because GitHub recently updated their HTTPS ciphersuite to only support TLS 1.1+. See this discourse page for more details. The long and the short of it is; we don't have any plans to release a new version of 0.5 that has an updated libgit2 that would support these newer TLS protocols, so the official advice is to upgrade to Julia 0.6+.

staticfloat commented Feb 25, 2018

This is because GitHub recently updated their HTTPS ciphersuite to only support TLS 1.1+. See this discourse page for more details. The long and the short of it is; we don't have any plans to release a new version of 0.5 that has an updated libgit2 that would support these newer TLS protocols, so the official advice is to upgrade to Julia 0.6+.

@galenlynch

This comment has been minimized.

Show comment
Hide comment
@galenlynch

galenlynch Feb 25, 2018

ok, thanks for the quick response!

galenlynch commented Feb 25, 2018

ok, thanks for the quick response!

@bghannad

This comment has been minimized.

Show comment
Hide comment
@bghannad

bghannad Mar 23, 2018

Hello everybody, is there anyway around it to use the Julia version 0.5 and add packages ?
I have some super important packages that are just working with v 0.5 and I can not give up on them :/

bghannad commented Mar 23, 2018

Hello everybody, is there anyway around it to use the Julia version 0.5 and add packages ?
I have some super important packages that are just working with v 0.5 and I can not give up on them :/

@aviks

This comment has been minimized.

Show comment
Hide comment
@aviks

aviks Mar 23, 2018

You can try building a version of 0.5 with an updated OpenSSL yourself.

aviks commented Mar 23, 2018

You can try building a version of 0.5 with an updated OpenSSL yourself.

@uripatish

This comment has been minimized.

Show comment
Hide comment
@uripatish

uripatish Mar 28, 2018

Hey @bghannad , I faced a similar problem, and downloading the packages manually and extracting them to the ~/.julia/v0.5 directory did the trick for me. Hope this might help.

uripatish commented Mar 28, 2018

Hey @bghannad , I faced a similar problem, and downloading the packages manually and extracting them to the ~/.julia/v0.5 directory did the trick for me. Hope this might help.

justinshenk referenced this issue in henrikbostrom/RandomForest Apr 11, 2018

luchr added a commit to luchr/ODEInterface.jl that referenced this issue Jun 28, 2018

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment