Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

Already on GitHub? Sign in to your account

GPG error for repository "http://extras.ubuntu.com" #163

Closed
gildegoma opened this Issue Mar 11, 2013 · 2 comments

Comments

Projects
None yet
2 participants
Member

gildegoma commented Mar 11, 2013

apt-get update on travis worker give following error

GPG error: http://extras.ubuntu.com precise Release: The following signatures couldn't be verified because the public key is not available: NO_PUBKEY 16126D3A3E5C1192

See this example.

In https://github.com/travis-ci/travis-cookbooks/tree/master/ci_environment/apt/templates, I noticed that only ubuntu-12.04/sources.list.erb enables this repository:

deb http://extras.ubuntu.com/ubuntu precise main
deb-src http://extras.ubuntu.com/ubuntu precise main

For previous releases (11.10, 11.04, 10.04), extras.ubuntu.com was not activated.

Question before taking actions:

Do we really need to activate this repository by default? What applications are there?

  • If yes, we may need to install it with its gpg key with an appropriate apt_repository LWRP.
  • if no, let's comment this repo out.
Contributor

michaelklishin commented Mar 11, 2013

That repository is not very relevant for server distributions. It contains things like non-free video codecs and other things that desktop users may need.

@gildegoma gildegoma closed this in 7144327 Mar 11, 2013

Member

gildegoma commented Mar 11, 2013

Thanks @michaelklishin for rapid confirmation. I configured it like in genuine ubuntu setup (extras.ubuntu.com and archive.canonical.com are disabled). We'll see, if any cookbook require something from one of these repositories... but I doubt.

Note: there was no GPG key error for archive.canonical.com, but I think it's better to stick to default repositories, unless this dependency is required.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment