Skip to content
This repository

HTTPS clone URL

Subversion checkout URL

You can clone with HTTPS or Subversion.

Download ZIP
branch: master

Jul 10, 2014

  1. Hiro Asari

    Clarify 'bin/travis-lint' replacement

    BanzaiMan authored

May 05, 2014

  1. Hiro Asari

    Point to travis-yaml instead

    BanzaiMan authored

Mar 13, 2014

  1. Henrik Hodne

    chore(version): release 1.8.0

    henrikhodne authored
  2. Hiro Asari

    Merge branch 'master' of github.com:travis-ci/travis-lint

    BanzaiMan authored
  3. Hiro Asari

    Recognize Ruby 2.1.1

    BanzaiMan authored
  4. Hiro Asari

    Validate 'language' value

    If the 'language' key is present, ensure that we have a validator
    for it.
    BanzaiMan authored

Feb 19, 2014

  1. Michael Klishin

    Merge pull request #50 from hkdobrev/php-56

    Add 5.6 to allowed PHP versions
    michaelklishin authored
  2. Haralan Dobrev

    Add 5.6 to allowed PHP versions

    hkdobrev authored

Jan 06, 2014

  1. Konstantin Haase

    Merge pull request #44 from floehopper/allow-mri-ruby-2.1.0

    Allow MRI Ruby 2.1.0.
    rkh authored
  2. James Mead

    fixup! Travis CI now supports MRI Ruby 2.1.0.

    floehopper authored
  3. James Mead

    Travis CI now supports MRI Ruby 2.1.0.

    floehopper authored

Jan 05, 2014

  1. Hiro Asari

    Update copyright year [skip ci]

    BanzaiMan authored
  2. Hiro Asari

    Downgrade RubyGems only for Ruby 1.8

    BanzaiMan authored
  3. Hiro Asari

    Revert "Remove before_install hook"

    This reverts commit 22f26d7.
    
    The hack seems still necessary for 1.8.x.
    BanzaiMan authored
  4. Hiro Asari

    Remove before_install hook

    Bundler and RubyGems are updated, so these commands are no longer
    necessary.
    BanzaiMan authored

Dec 31, 2013

  1. Henrik Hodne

    Merge pull request #42 from travis-ci/ha-bug-gh_41

    Print YAML syntax error message
    henrikhodne authored

Dec 30, 2013

  1. Hiro Asari

    Update RubyGems, too.

    BanzaiMan authored
  2. Hiro Asari

    Install Bundler 1.5.1 due to a bug

    BanzaiMan authored
  3. Hiro Asari

    Add error message when file fails to load

    BanzaiMan authored

Dec 19, 2013

  1. Michael Klishin

    Merge pull request #39 from davedevelopment/hhvm

    Add hhvm to list of supported php versions
    michaelklishin authored
  2. Dave Marshall

    Add hhvm to list of supported php versions

    davedevelopment authored

Dec 15, 2013

  1. Michael Klishin

    Merge pull request #38 from sanemat/feature/ruby-2-1-0-alias

    Add known ruby versions
    michaelklishin authored
  2. Murahashi Sanemat Kenichi

    Add known ruby versions

    - 2.1.0-preview1
    - 2.1.0-preview2
    There already exist ruby-2.1.0-preview{1,2}
    sanemat authored

Nov 30, 2013

  1. Konstantin Haase

    Merge pull request #37 from brixen/master

    Updated validators for Rubinius. Fixes #36.
    rkh authored
  2. Brian Shirai

    Add gem 'rubysl' to Gemfile for Rubinius.

    brixen authored
  3. Brian Shirai

    Remove rbx-1[89]mode from .travis.yml.

    brixen authored
  4. Brian Shirai

    Update validators for rbx. Fixes #36.

    brixen authored
  5. Brian Shirai

    Update specs for rbx-1[89]mode being invalid.

    brixen authored
  6. Brian Shirai

    Fix rspec deprecation warning on arguments to #raise_error.

    The deprecation warning was:
    
    DEPRECATION: `expect { }.not_to raise_error(SpecificErrorClass, message)` is
    deprecated. Use `expect { }.not_to raise_error` (with no args) instead. Called
    from /source/travis-ci/travis-lint/spec/travis_lint_runner_spec.rb:93:in
    `__script__'.
    brixen authored

Nov 25, 2013

  1. Mathias Meyer

    Remove Python 2.5, add custom Ruby builds.

    roidrage authored

Nov 01, 2013

  1. Josh Kalderimis

    Merge pull request #34 from mbeijen/perl-supported-versions

    Added supported perl versions on travis to linter.
    joshk authored
  2. Josh Kalderimis

    an s makes all the difference

    joshk authored
  3. Josh Kalderimis

    allow *-head to fail

    joshk authored

Oct 31, 2013

  1. Michiel Beijen

    Added supported perl versions on travis to linter.

    This is the second try after pull#33.
    
    I now added the supported perl versions in the correct place.
    Also, I found not only the problem is that perl 5.8 is supported on
    Travis and is rejected by the linter (although I understand it is
    not /fully/ supported, or at the least, if it breaks not many people
    will care), but also perl 5.18, which is the latest stable perl, and
    perl 5.19 ARE available on travis but are rejected by the linter.
    
    So I made sure these are now accepted.
    mbeijen authored

May 24, 2013

  1. Henrik Hodne

    Merge pull request #29 from tomdcc/lint-include

    Lint matrix include node
Something went wrong with that request. Please try again.