New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

Supporting multiple deploy providers with travis setup #201

Open
konfiot opened this Issue Jun 14, 2014 · 3 comments

Comments

Projects
None yet
5 participants
@konfiot

konfiot commented Jun 14, 2014

Hello,
I'm trying to deploy on multiple providers (divshot for static files and openshift for the app), and when I try to do travis setup openshift I'm answered deploy section already exists in .travis.yml, run with --force to override
And when adding --force, all the old config is deleted
Thanks in advance

@Aaron1011

This comment has been minimized.

Show comment
Hide comment
@Aaron1011

Aaron1011 Aug 13, 2014

Contributor

@konfiot: This is because the travis setup command has no support for multiple providers - it overwrites whatever is there.

This would be a good feature, I'm going to submit a PR adding it soon.

Contributor

Aaron1011 commented Aug 13, 2014

@konfiot: This is because the travis setup command has no support for multiple providers - it overwrites whatever is there.

This would be a good feature, I'm going to submit a PR adding it soon.

@rkh

This comment has been minimized.

Show comment
Hide comment
@rkh

rkh Aug 13, 2014

Member

<3

On Wed, Aug 13, 2014 at 8:49 PM, Aaron1011 notifications@github.com wrote:

@konfiot https://github.com/konfiot: This is because the travis setup
command has no support for multiple providers - it overwrites whatever is
there.

This would be a good feature, I'm going to submit a PR adding it soon.


Reply to this email directly or view it on GitHub
#201 (comment).

Member

rkh commented Aug 13, 2014

<3

On Wed, Aug 13, 2014 at 8:49 PM, Aaron1011 notifications@github.com wrote:

@konfiot https://github.com/konfiot: This is because the travis setup
command has no support for multiple providers - it overwrites whatever is
there.

This would be a good feature, I'm going to submit a PR adding it soon.


Reply to this email directly or view it on GitHub
#201 (comment).

@floriangosse

This comment has been minimized.

Show comment
Hide comment
@floriangosse

floriangosse Oct 4, 2016

Is there any progress?

floriangosse commented Oct 4, 2016

Is there any progress?

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment