`-r` flag results in NoMethodError #3

Closed
BanzaiMan opened this Issue Jan 15, 2013 · 3 comments

Projects

None yet

3 participants

@BanzaiMan
Owner

http://about.travis-ci.org/blog/2012-12-18-travis-artifacts/ advises the use of -r flag when encrypting AWS credentials for uploads. This now results in NoMethodError:

$ travis encrypt ARTIFACTS_AWS_SECRET_ACCESS_KEY=blabblah -r foo/bar
/Users/asari/.rvm/gems/ruby-1.9.3-p327@libra/gems/travis-1.0.2/lib/travis/cli/repo_command.rb:7:in `block in <class:RepoCommand>': undefined local variable or method `slug' for Travis::CLI::RepoCommand:Class (NameError)
        from /Users/asari/.rvm/gems/ruby-1.9.3-p327@libra/gems/travis-1.0.2/lib/travis/cli/parser.rb:29:in `call'
        from /Users/asari/.rvm/gems/ruby-1.9.3-p327@libra/gems/travis-1.0.2/lib/travis/cli/parser.rb:29:in `block (2 levels) in on'
        from /Users/asari/.rvm/rubies/ruby-1.9.3-p327/lib/ruby/1.9.1/optparse.rb:1391:in `call'
        from /Users/asari/.rvm/rubies/ruby-1.9.3-p327/lib/ruby/1.9.1/optparse.rb:1391:in `block in parse_in_order'
        from /Users/asari/.rvm/rubies/ruby-1.9.3-p327/lib/ruby/1.9.1/optparse.rb:1347:in `catch'
        from /Users/asari/.rvm/rubies/ruby-1.9.3-p327/lib/ruby/1.9.1/optparse.rb:1347:in `parse_in_order'
        from /Users/asari/.rvm/rubies/ruby-1.9.3-p327/lib/ruby/1.9.1/optparse.rb:1341:in `order!'
        from /Users/asari/.rvm/rubies/ruby-1.9.3-p327/lib/ruby/1.9.1/optparse.rb:1432:in `permute!'
        from /Users/asari/.rvm/rubies/ruby-1.9.3-p327/lib/ruby/1.9.1/optparse.rb:1453:in `parse!'
        from /Users/asari/.rvm/rubies/ruby-1.9.3-p327/lib/ruby/1.9.1/optparse.rb:1443:in `parse'
        from /Users/asari/.rvm/gems/ruby-1.9.3-p327@libra/gems/travis-1.0.2/lib/travis/cli/command.rb:87:in `parse'
        from /Users/asari/.rvm/gems/ruby-1.9.3-p327@libra/gems/travis-1.0.2/lib/travis/cli.rb:39:in `run'
        from /Users/asari/.rvm/gems/ruby-1.9.3-p327@libra/gems/travis-1.0.2/bin/travis:4:in `<top (required)>'
        from /Users/asari/.rvm/gems/ruby-1.9.3-p327@libra/bin/travis:19:in `load'
        from /Users/asari/.rvm/gems/ruby-1.9.3-p327@libra/bin/travis:19:in `<main>'
        from /Users/asari/.rvm/gems/ruby-1.9.3-p327@libra/bin/ruby_noexec_wrapper:14:in `eval'
        from /Users/asari/.rvm/gems/ruby-1.9.3-p327@libra/bin/ruby_noexec_wrapper:14:in `<main>'
@rkh rkh closed this in 642f6ea Jan 15, 2013
Owner
rkh commented Jan 15, 2013

Fixed. Also, if you're in the project directory, you don't need the -r part.

Owner

do we need to update any docs?

On Jan 15, 2013, at 8:44 PM, Konstantin Haase notifications@github.com wrote:

Fixed. Also, if you're in the project directory, you don't need the -r part/


Reply to this email directly or view it on GitHub.

Owner
rkh commented Jan 15, 2013

No.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment