Skip to content
This repository

Installation document #5

Open
hoschi opened this Issue October 14, 2011 · 4 comments

2 participants

Stefan Gojan Tristan Ravitch
Stefan Gojan

I tried to install cabal install:

cabal install taffybar
Resolving dependencies...  
cabal: dependencies conflict: xmonad-contrib-0.10 requires mtl ==1.1.0.2
however
mtl-1.1.0.2 was excluded because taffybar-0.1.3 requires mtl >=2

A document to show how I install it from source would be nice.

Tristan Ravitch
Owner
Stefan Gojan

here are my version details:

~ > cabal --version                                                            
cabal-install version 0.8.0
using version 1.8.0.2 of the Cabal library
~ > ghc --version 
The Glorious Glasgow Haskell Compilation System, version 6.12.1

I'm under Ubuntu maverick.

Tristan Ravitch
Owner

Thanks. I finally got around to looking at this. I was unable to reproduce your exact error - mtl2 should really
just work with xmonad/xmonad-contrib/taffybar.

Unfortunately, for independent reasons it looks like it will only work with ghc7 at the moment. There are two
problems: my cabal version requirements were a bit high and it looks like 6.12 doesn't like something about
some of my FFI declarations. It should be possible to make it compatible with both, so I'll try to release an
updated package soon.

Stefan Gojan

Nice! Update the issue if you finished it and I test it again ;)

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.