Skip to content
New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

problem with recent changes #18

Closed
lollul opened this issue Jun 3, 2019 · 1 comment

Comments

Projects
None yet
2 participants
@lollul
Copy link

commented Jun 3, 2019

I've tried to update to current version but facing errors:

2019/06/03 10:40:04 [error] 424#424: *23 FastCGI sent in stderr: "PHP message: PHP Warning:  require_once(/var/www/air-quality-info): failed to open stream: Success in /var/www/air-quality-info/boot.php on line 11
PHP message: PHP Fatal error:  require_once(): Failed opening required '' (include_path='.:/usr/share/php') in /var/www/air-quality-info/boot.php on line 11" while reading response header from upstream, client: x.x.x.x, server: zlawies.eu, request: "GET / HTTP/1.1", upstream: "fastcgi://unix:/var/run/php/php7.0-fpm.sock:", host: "xxx.xxx"

All I could understand from the above is that it has a problem finding config.php. I then reverted the recent changes in boot.php related to config.php only to reach another error:

2019/06/03 10:05:37 [error] 31324#31324: *187497 FastCGI sent in stderr: "PHP message: PHP Fatal error:  Uncaught Exception: Can't load file /lib/di_container.php for class AirQualityInfo\Lib\DiContainer in /var/www/air-quality-info/boot.php:22
Stack trace:
#0 [internal function]: AirQualityInfo\{closure}('AirQualityInfo\\...')
#1 /var/www/air-quality-info/boot.php(27): spl_autoload_call('AirQualityInfo\\...')
#2 /var/www/air-quality-info/index.php(4): require('/var/www/air-qu...')
#3 {main}
  thrown in /var/www/air-quality-info/boot.php on line 22" while reading response header from upstream, client: x.x.x.x, server: zlawies.eu, request: "GET / HTTP/1.1", upstream: "fastcgi://unix:/var/run/php/php7.0-fpm.sock:", host: "xxx.xxx"

I've now rolled back to Mar 23 version and all is fine.
I'm running this on a ubuntu 16.04 OpenVz VPS server. Are there new requirements for PHP or fpm etc?

@trekawek

This comment has been minimized.

Copy link
Owner

commented Jun 4, 2019

@lollul - yes, the standalone version is no longer supported. The new docker-compose.yml file should allow to start the service (see README), but the data has to be migrated manually.

@trekawek trekawek closed this Jun 4, 2019

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
You can’t perform that action at this time.