Permalink
Commits on Jul 18, 2014
  1. Updated the latest version of TinyMCE, v4.1.2.

    This is potentially unstable. I've tested in a vanilla Rails 3 app,
    and the combined javascript file loads and the editor renders. Beyond
    that I have not verified any functionality.
    
    Major changes:
    
    * Removed the default language of ['en'] from Tinymce::Hammer.languages.
      You can add non 'en' entries and they should still load.
    
    * Changed the default theme from 'advanced' to 'modern'. The advanced
      theme is no longer available as of tinymce 4.
    
    * Removed some of the default init values that were specific to the
      'advanced' theme.
    
    * Removed the ability to toggle source vs minified. The option still
      exists, but this release of tinymce did not ship with non-minified
      source.
    
    * Updated the paths to plugin and theme js files to combine correctly.
    committed Jul 18, 2014
Commits on Dec 2, 2010
  1. The old init configuration now fully supported

    Trevor Rowe committed Dec 2, 2010
Commits on Dec 1, 2010
  1. updated rails supported version number to 3.0

    Trevor Rowe committed Dec 1, 2010
  2. updated readme with information about latest updates

    Trevor Rowe committed Dec 1, 2010
  3. A ruby Hash is now accepted to Tinymce::Hammer.init

    Previously only a 2D array of key value pairs was accepted.  This is
    because ruby hashes are not ordered and certain init keys had to
    appear before others.
    
    If you use a hash your configuration values will be added in alphabetical
    order by their stringified-keys.  If this does not work, you may still use
    the array of arrays approach.
    Trevor Rowe committed Dec 1, 2010
  4. Cleaned up caching methods of the combined js

    You can now cache the combined js by calling Tinymce::Hammer.cache_js or
    by running rake tinymce:cache_js.  If you always want a current copy and to
    avoid the overhead of rails combining in development, go ahead and call
    cache_js at the bottom of your config/tinymce_hammer.rb file.
    
    Use the rake task and commit the file to your repository to make the comabined
    js file play nicely with services like Heroku where writing files after deploy
    is a no-no.
    Trevor Rowe committed Dec 1, 2010
  5. removed the old plugin generators folder, its been moved to lib/gener…

    …ators
    Trevor Rowe committed Dec 1, 2010
  6. tinymce_hammer is now Rails 3.0 compatible

    The plugin continues to be Rails 2.3+ compatible.  I'll be updating the
    readme with information about how to run the generators in the next commit.
    Trevor Rowe committed Dec 1, 2010
Commits on Feb 8, 2010
  1. Upgraded bundled TinyMCE installation to version 3.3b2

    To upgrade your installed version run ./script/generate tinymce_insallation
    Trevor Rowe committed Feb 8, 2010
Commits on Jan 4, 2010
  1. Removed heredoc style strings and replaced with double quoted multi l…

    …ine strings
    Trevor Rowe committed Jan 4, 2010
Commits on Oct 12, 2009
  1. Updated the domReady loading to resolve a possible ie7 crash.

    The domReady library was having issues with IE7, the code has been updated
    in the combined file to provide a less-obtrusive dom-content-loaded function
    for initializing TinyMCE.
    committed Oct 12, 2009
Commits on Oct 2, 2009
Commits on Sep 15, 2009
  1. Merge branch 'master' of git@github.com:trevorrowe/tinymce_hammer

    * 'master' of git@github.com:trevorrowe/tinymce_hammer:
      Added Tinymce::Hammer.src as a config option.
    committed Sep 15, 2009
  2. Added a domready function to init tinymce hammer

    Ran into an issue where other javascript files would interfere
    with the overly-simplistic method of adding the TinymceHammer.init funciton
    to the window onload event.  domReady has been added to the combined js file which
    now initializes tinymce hammer after the dom content has loaded.
    committed Sep 15, 2009
  3. Added Tinymce::Hammer.src as a config option.

    If Tinymce::Hammer.src is true, the combined javascript file will be the
    _src suffixed javascript files.  This makes it easier to debug js issues
    with the combined librarires and plugins.
    committed Sep 15, 2009
Commits on Aug 19, 2009
  1. Upgraded bundled TinyMCE installation to 3.2.6

    To upgrade just run ./script/generate tinymce_installation.  If you would like to remove
    You can also optionally remove the now deprecated (removed from the generator as well) plugin
    compat2x (3x has been out for over a year).
    
    You can read the changelog here: http://tinymce.moxiecode.com/changelog.php
    committed Aug 19, 2009
Commits on Aug 18, 2009
  1. Added a js helper method that makes it easy to add editors after page…

    … load.
    
    Just call TinymceHammer.addEditor(dom_id) (dom id is the dom id of an element
    on the page) and it will be made into a TinyMCE editor.
    committed Aug 18, 2009
Commits on Jul 29, 2009
  1. added support for setup callback handler

    brent committed with Jul 28, 2009
  2. Separated url_path from install_path to support Rails apps in subdire…

    …ctories.
    
    The install_path (path from Rails_ROOT/public) won't match the url_path
    to the TinyMCE installation when Rails is hosted in a subdirectory.
    Tinymce::Hammer.url_path can now be set to resolve this issue.
    
    This patch is based heavily on the excellent suggestion and patch submitted
    by bbeardsley.
    committed Jul 29, 2009
Commits on Jul 13, 2009
  1. Added language to tinymce_hammer_javascript_tags

    This view helper previously ignored the plugin language preferences.
    It now sets the language to the first language in the Tinymce::Hammer.language
    as the init.language option.
    committed Jul 13, 2009
Commits on Jul 7, 2009
  1. Removed a bad example from the README

    The readme had a sample configuration the referenced paste2.  The paste2
    plugin was removed from tinymce and is now part of paste.  The new
    committed Jul 7, 2009
  2. Fixed a generator bug, was missing a directory

    If you were running the tinymce_installation generator for the first
    time (not running to upgrade installation) and exception is raised because
    files are trying to be copied into a directory that doesn't exist.
    
    I've added the missing directory rule for the inlinepopups plugin to resolve
    the issue.
    
    Thanks to bking39116 for bringing this to my attention.
    committed Jul 7, 2009
Commits on Jul 6, 2009
  1. Upgraded bundled TinyMCE to 3.2.5

    You can upgrade your installation by running the following:
    
      ./script/generate tinymce_installation
    
    Answer with 'a' and it will auto-overwrite all modified files.  You can also
    skip this and just upgrade your installation yourself.
    committed Jul 6, 2009
Commits on Jun 10, 2009
  1. updated REAMDE.rdoc

    committed Jun 10, 2009
  2. added ./script/generate tinymce_installation

    Added a proper tinymce_installation generator that obeys your
    Tinymce::Hammer.isntall_path configuration.
    committed Jun 10, 2009
Commits on Jun 9, 2009
  1. Now bundles TinyMCE with the plugin

    Also added a rake tasks (rake tinymce:install) that copies the installation
    to your prefered directory.
    committed Jun 9, 2009
Commits on Jun 8, 2009