Permalink
Browse files

- Update dependencies

- Conform to better standard for gemifying assets
- Increment version to 0.0.2
  • Loading branch information...
1 parent e359594 commit cbb6ea056bf2cd8061cf7e198e5c9f64eaf36bcf @treydock committed Apr 13, 2012
Showing with 14 additions and 12 deletions.
  1. +1 −5 Gemfile
  2. +7 −2 bad_browser.gemspec
  3. +5 −4 lib/bad_browser.rb
  4. +1 −1 lib/bad_browser/version.rb
View
@@ -1,8 +1,4 @@
source 'https://rubygems.org'
# Specify your gem's dependencies in bad_browser.gemspec
-gemspec
-
-gem "jquery-rails"
-gem "rspec"
-gem "rspec-rails"
+gemspec
View
@@ -8,14 +8,19 @@ Gem::Specification.new do |gem|
gem.summary = %{'Unsupported browser' warning to IE users with Chrome Frame install link, for Rails (>= 3.1)}
gem.homepage = "https://github.com/treydock/bad_browser"
- gem.executables = `git ls-files -- bin/*`.split("\n").map{ |f| File.basename(f) }
gem.files = `git ls-files`.split("\n")
gem.test_files = `git ls-files -- {test,spec,features}/*`.split("\n")
gem.name = "bad_browser"
gem.require_paths = ["lib"]
gem.version = BadBrowser::VERSION
gem.add_dependency "rails", "~> 3.1.0"
- gem.add_dependency "activesupport", "~> 3.1.0"
+# gem.add_dependency "railties", "~> 3.1.0"
+ gem.add_dependency "actionpack", "~> 3.1.0"
+ gem.add_dependency "jquery-rails"
+
+ # Development only requirements (unused at this point)
+# gem.add_development_dependency "rspec"
+# gem.add_development_dependency "rspec-rails"
end
View
@@ -1,11 +1,12 @@
-require "rails/engine"
require "bad_browser/version"
require "bad_browser/view_helpers"
module BadBrowser
- class Engine < Rails::Engine
- initializer "bad_browser.view_helpers" do
- ActionView::Base.send :include, ViewHelpers
+ module Rails
+ class Engine < ::Rails::Engine
+ initializer "bad_browser.view_helpers" do
+ ActionView::Base.send :include, ViewHelpers
+ end
end
end
end
@@ -1,3 +1,3 @@
module BadBrowser
- VERSION = "0.0.1"
+ VERSION = "0.0.2"
end

0 comments on commit cbb6ea0

Please sign in to comment.