Permalink
Browse files

sort out gemfiles

  • Loading branch information...
paulca committed Feb 6, 2011
1 parent 585827e commit 846a436db9ceb217b4bd0c69bf141d1caabd3ed4
Showing with 18 additions and 12 deletions.
  1. +6 −4 Gemfile
  2. +3 −2 Rakefile
  3. +9 −6 configurable_engine.gemspec
View
10 Gemfile
@@ -1,6 +1,8 @@
source 'http://rubygems.org'
-gem 'rake'
-gem 'jeweler'
-gem 'rspec'
-gem 'cucumber'
+group :development
+ gem 'rake'
+ gem 'jeweler'
+ gem 'rspec'
+ gem 'cucumber'
+end
View
@@ -21,8 +21,9 @@ Jeweler::Tasks.new do |gem|
gem.authors = ["Paul Campbell"]
# Include your dependencies below. Runtime dependencies are required when using your gem,
# and development dependencies are only needed for development (ie running rake tasks, tests, etc)
- gem.add_runtime_dependency 'rails', '~>3.0.0'
- gem.add_runtime_dependency 'activerecord', '~>3.0.0'
+ gem.add_runtime_dependency 'rails', '~>3.0'
+ gem.add_runtime_dependency 'activerecord', '~>3.0'
+ gem.add_runtime_dependency 'builder', '~>2.1.2'
gem.files = FileList["[A-Za-z]*", "lib/**/*", "app/**/*", "config/*"]
# gem.add_development_dependency 'rspec', '> 1.2.3'
end
@@ -5,7 +5,7 @@
Gem::Specification.new do |s|
s.name = %q{configurable_engine}
- s.version = "0.2.2"
+ s.version = "0.2.3"
s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
s.authors = ["Paul Campbell"]
@@ -51,22 +51,25 @@ Gem::Specification.new do |s|
s.add_runtime_dependency(%q<rspec>, [">= 0"])
s.add_runtime_dependency(%q<cucumber>, [">= 0"])
s.add_runtime_dependency(%q<rails>, ["~> 3.0"])
- s.add_runtime_dependency(%q<activerecord>, ["~> 3"])
+ s.add_runtime_dependency(%q<activerecord>, ["~> 3.0"])
+ s.add_runtime_dependency(%q<builder>, ["~> 2.1.2"])
else
s.add_dependency(%q<rake>, [">= 0"])
s.add_dependency(%q<jeweler>, [">= 0"])
s.add_dependency(%q<rspec>, [">= 0"])
s.add_dependency(%q<cucumber>, [">= 0"])
- s.add_dependency(%q<rails>, ["~> 3"])
- s.add_dependency(%q<activerecord>, ["~> 3"])
+ s.add_dependency(%q<rails>, ["~> 3.0"])
+ s.add_dependency(%q<activerecord>, ["~> 3.0"])
+ s.add_dependency(%q<builder>, ["~> 2.1.2"])
end
else
s.add_dependency(%q<rake>, [">= 0"])
s.add_dependency(%q<jeweler>, [">= 0"])
s.add_dependency(%q<rspec>, [">= 0"])
s.add_dependency(%q<cucumber>, [">= 0"])
- s.add_dependency(%q<rails>, ["~> 3"])
- s.add_dependency(%q<activerecord>, ["~> 3"])
+ s.add_dependency(%q<rails>, ["~> 3.0"])
+ s.add_dependency(%q<activerecord>, ["~> 3.0"])
+ s.add_dependency(%q<builder>, ["~> 2.1.2"])
end
end

0 comments on commit 846a436

Please sign in to comment.