Skip to content
Permalink
Browse files

Downgrade npm to 10 on Centos 6 for build problems

Centos-6 does not fulfill the dependencies for npm 12 and therefor the the docker build fails.

Change-Id: I0c9c73191a49b6226123bb73ba7f5660d2afb2c3
  • Loading branch information...
AZurhake committed May 14, 2019
1 parent 6460395 commit de4a9ecbdb682469c0886f0ee7fcd49e61f269fc
Showing with 1 addition and 1 deletion.
  1. +1 −1 buildscripts/infrastructure/os-nodes/centos-6/Dockerfile
@@ -34,7 +34,7 @@ RUN curl https://bootstrap.pypa.io/get-pip.py -o get-pip.py \
&& scl enable python27 'python get-pip.py' \
&& scl enable python27 'pip install --upgrade setuptools virtualenv' \
&& scl enable python27 'pip install git+https://github.com/pypa/pipenv.git' \
&& curl -sL https://rpm.nodesource.com/setup_12.x | bash -
&& curl -sL https://rpm.nodesource.com/setup_10.x | bash -
RUN yum -y install \
nodejs \
$PACKAGES \

0 comments on commit de4a9ec

Please sign in to comment.
You can’t perform that action at this time.