New issue

Have a question about this project? Sign up for a free GitHub account to open an issue and contact its maintainers and the community.

By clicking “Sign up for GitHub”, you agree to our terms of service and privacy statement. We’ll occasionally send you account related emails.

Already on GitHub? Sign in to your account

trigger won't install with modern setuptools #313

Closed
tarkatronic opened this Issue Mar 7, 2017 · 2 comments

Comments

Projects
None yet
2 participants
@tarkatronic

tarkatronic commented Mar 7, 2017

With setuptools==34.3.1 installed, when running pip install trigger, I get the following:

    Complete output from command python setup.py egg_info:
    Traceback (most recent call last):
      File "<string>", line 1, in <module>
      File "/Users/jwilhelm/.virtualenvs/trigger-py2/lib/python2.7/site-packages/setuptools/__init__.py", line 12, in <module>
        import setuptools.version
      File "/Users/jwilhelm/.virtualenvs/trigger-py2/lib/python2.7/site-packages/setuptools/version.py", line 1, in <module>
        import pkg_resources
      File "/Users/jwilhelm/.virtualenvs/trigger-py2/lib/python2.7/site-packages/pkg_resources/__init__.py", line 72, in <module>
        import packaging.requirements
      File "/Users/jwilhelm/.virtualenvs/trigger-py2/lib/python2.7/site-packages/packaging/requirements.py", line 59, in <module>
        MARKER_EXPR = originalTextFor(MARKER_EXPR())("marker")
    TypeError: __call__() takes exactly 2 arguments (1 given)

    ----------------------------------------
Command "python setup.py egg_info" failed with error code 1 in /private/var/folders/mx/gn154d8j3254p213qkhd6n3mlnym4m/T/pip-build-WU_p8B/pyparsing/

I was able to work around this by first running pip install setuptools==0.9.8.

@tarkatronic

This comment has been minimized.

tarkatronic commented Mar 8, 2017

It looks like you actually can use an even more modern version of setuptools. A simple fix for now would be to add a requires of: setuptools <= 33.1.1

@jathanism

This comment has been minimized.

Member

jathanism commented Mar 8, 2017

Looks like it may actually be an issue w/ pyparsing and not Trigger. See: pypa/setuptools#969

@jathanism jathanism added the bug label Mar 8, 2017

@jathanism jathanism self-assigned this Mar 8, 2017

jathanism added a commit to jathanism/trigger that referenced this issue Mar 8, 2017

@tcuthbert tcuthbert closed this in 51ae04c Mar 8, 2017

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment