Permalink
Browse files

Update dependencies and fix test failures.

  • Loading branch information...
1 parent 5a6e730 commit 9bf826814ef5fc4a89ac328042e9061e93d5e8b4 @tristandunn committed Mar 29, 2012
View
@@ -7,12 +7,12 @@ group :assets do
gem "closure-compiler", "1.1.6"
gem "bourbon", "1.4.0"
gem "ejs", "1.0.0"
- gem "sass-rails", "3.2.4"
+ gem "sass-rails", "3.2.5"
gem "yui-compressor", "0.9.6"
end
group :test do
- gem "capybara-webkit", "0.10.1"
+ gem "capybara-webkit", "0.11.0"
gem "cucumber-rails", "1.3.0", require: false
- gem "rspec-rails", "2.8.1"
+ gem "rspec-rails", "2.9.0"
end
View
@@ -43,7 +43,7 @@ GEM
rack-test (>= 0.5.4)
selenium-webdriver (~> 2.0)
xpath (~> 0.1.4)
- capybara-webkit (0.10.1)
+ capybara-webkit (0.11.0)
capybara (>= 1.0.0, < 1.2)
json
childprocess (0.3.1)
@@ -65,18 +65,18 @@ GEM
erubis (2.7.0)
eventmachine (0.12.10)
ffi (1.0.11)
- gherkin (2.9.0)
+ gherkin (2.9.3)
json (>= 1.4.6)
hike (1.2.1)
i18n (0.6.0)
journey (1.0.3)
- json (1.6.5)
- mail (2.4.3)
+ json (1.6.6)
+ mail (2.4.4)
i18n (>= 0.4.0)
mime-types (~> 1.16)
treetop (~> 1.4.8)
- mime-types (1.17.2)
- multi_json (1.1.0)
+ mime-types (1.18)
+ multi_json (1.2.0)
nokogiri (1.5.2)
open4 (1.3.0)
polyglot (0.3.3)
@@ -105,22 +105,22 @@ GEM
rake (0.9.2.2)
rdoc (3.12)
json (~> 1.4)
- rspec (2.8.0)
- rspec-core (~> 2.8.0)
- rspec-expectations (~> 2.8.0)
- rspec-mocks (~> 2.8.0)
- rspec-core (2.8.0)
- rspec-expectations (2.8.0)
- diff-lcs (~> 1.1.2)
- rspec-mocks (2.8.0)
- rspec-rails (2.8.1)
+ rspec (2.9.0)
+ rspec-core (~> 2.9.0)
+ rspec-expectations (~> 2.9.0)
+ rspec-mocks (~> 2.9.0)
+ rspec-core (2.9.0)
+ rspec-expectations (2.9.0)
+ diff-lcs (~> 1.1.3)
+ rspec-mocks (2.9.0)
+ rspec-rails (2.9.0)
actionpack (>= 3.0)
activesupport (>= 3.0)
railties (>= 3.0)
- rspec (~> 2.8.0)
+ rspec (~> 2.9.0)
rubyzip (0.9.6.1)
sass (3.1.15)
- sass-rails (3.2.4)
+ sass-rails (3.2.5)
railties (~> 3.2.0)
sass (>= 3.1.10)
tilt (~> 1.3)
@@ -154,12 +154,12 @@ PLATFORMS
DEPENDENCIES
bourbon (= 1.4.0)
- capybara-webkit (= 0.10.1)
+ capybara-webkit (= 0.11.0)
closure-compiler (= 1.1.6)
cucumber-rails (= 1.3.0)
ejs (= 1.0.0)
rails (= 3.2.2)
- rspec-rails (= 2.8.1)
- sass-rails (= 3.2.4)
+ rspec-rails (= 2.9.0)
+ sass-rails (= 3.2.5)
thin (= 1.3.1)
yui-compressor (= 0.9.6)
@@ -4,7 +4,7 @@ Reading.Models.Item = Backbone.Model.extend({
},
initialize: function() {
- var publishedAt = moment(this.get("publishedAt"));
+ var publishedAt = moment(new Date(this.get("publishedAt")));
this.formattedTime = publishedAt.format("h:mm A");
this.formattedDate = publishedAt.format("dddd, MMMM D, YYYY");
Oops, something went wrong. Retry.

0 comments on commit 9bf8268

Please sign in to comment.