Permalink
Browse files

Bumped the FFI dependency to 1.0+.

  • Loading branch information...
1 parent 0ab894d commit d1d92768115b1c4ce4b375e7967d62265e24457f @bendiken bendiken committed Dec 1, 2010
Showing with 6 additions and 2 deletions.
  1. +1 −1 .gemspec
  2. +1 −1 README.md
  3. +4 −0 lib/trith.rb
View
@@ -27,7 +27,7 @@ Gem::Specification.new do |gem|
gem.required_ruby_version = '>= 1.8.1'
gem.requirements = []
- gem.add_runtime_dependency 'ffi', '>= 0.6'
+ gem.add_runtime_dependency 'ffi', '>= 1.0'
gem.add_runtime_dependency 'backports', '>= 1.18'
gem.add_runtime_dependency 'promise', '>= 0.3'
gem.add_runtime_dependency 'sxp', '>= 0.0.12'
View
@@ -258,7 +258,7 @@ Dependencies
* [RDF.rb](http://rubygems.org/gems/rdf) (>= 0.3.0)
* [SXP](http://rubygems.org/gems/sxp) (>= 0.0.12)
* [Promise](http://rubygems.org/gems/promise) (>= 0.3.0)
-* [FFI](http://rubygems.org/gems/ffi) (>= 0.6.3)
+* [FFI](http://rubygems.org/gems/ffi) (>= 1.0.0)
Installation
------------
View
@@ -17,8 +17,12 @@
require 'rdf/ntriples'
require 'rdf/nquads'
+# @see http://rubygems.org/gems/ffi
+require 'ffi'
+
module Trith
include RDF
+
autoload :VERSION, 'trith/version'
# Runtime

0 comments on commit d1d9276

Please sign in to comment.