Skip to content

HTTPS clone URL

Subversion checkout URL

You can clone with
or
.
Download ZIP

Loading…

Errors when running gem install on mac #7

Open
ProLoser opened this Issue · 6 comments

5 participants

@ProLoser
$ sudo gem install xiki
Password:
ERROR:  Error installing xiki:
    ruby_parser requires sexp_processor (~> 3.0, runtime)
@trogdoro
Owner
@ProLoser
@xiongchiamiov

So since ruby_parser is broken and appears to be rather dead, perhaps you should add sexp_processor as a dependency?

@larsimmisch

On snow leopard, installing the transitive dependencies explicitly alone wasn't enough. I also had to do a:
sudo gem update --system

@jnovack

Still having errors. 10.8.1 :(

$ sudo gem install sexp_processor
Successfully installed sexp_processor-4.0.1
$ sudo gem update --system
Successfully installed rubygems-update-1.8.24
$ sudo gem install xiki

ERROR:  While generating documentation for activesupport-3.2.8
... MESSAGE:   exit
... RDOC args: --ri --op /Library/Ruby/Gems/1.8/doc/activesupport-3.2.8/ri --encoding UTF-8 lib --title activesupport-3.2.8 Documentation --quiet
$ gem -v
1.8.24
$ ruby -v
ruby 1.8.7 (2012-02-08 patchlevel 358) [universal-darwin12.0]
@trogdoro
Owner

I think that error only had to do with generating the docs for a gem. Shouldn't be an issue.

Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment
Something went wrong with that request. Please try again.