Skip to content
Browse files

MINOR Included required gems in gemspec

MINOR updated gemspec info
  • Loading branch information...
1 parent 4880a87 commit f10b4ab086c318829f397768fe360f980fd2b4b3 @juandebravo juandebravo committed Sep 8, 2011
Showing with 44 additions and 76 deletions.
  1. +1 −9 Gemfile
  2. +18 −6 Gemfile.lock
  3. +0 −1 VERSION
  4. +25 −60 tropo-provisioning.gemspec
View
10 Gemfile
@@ -1,11 +1,3 @@
source 'http://rubygems.org'
-gem 'activesupport'
-gem 'hashie'
-gem 'i18n'
-
-group :development do
- gem 'rspec'
- gem 'fakeweb'
- gem 'yard'
-end
+gemspec
View
24 Gemfile.lock
@@ -1,11 +1,22 @@
+PATH
+ remote: .
+ specs:
+ tropo-provisioning (0.0.21)
+ activesupport
+ hashie (>= 0.2.1)
+ i18n
+
GEM
remote: http://rubygems.org/
specs:
- activesupport (3.0.3)
+ activesupport (3.1.0)
+ multi_json (~> 1.0)
diff-lcs (1.1.2)
fakeweb (1.3.0)
- hashie (0.4.0)
- i18n (0.5.0)
+ hashie (1.1.0)
+ i18n (0.6.0)
+ multi_json (1.0.3)
+ rdoc (3.9.4)
rspec (2.3.0)
rspec-core (~> 2.3.0)
rspec-expectations (~> 2.3.0)
@@ -14,13 +25,14 @@ GEM
rspec-expectations (2.3.0)
diff-lcs (~> 1.1.2)
rspec-mocks (2.3.0)
+ yard (0.7.2)
PLATFORMS
ruby
DEPENDENCIES
- activesupport
fakeweb
- hashie
- i18n
+ rdoc
rspec
+ tropo-provisioning!
+ yard
View
1 VERSION
@@ -1 +0,0 @@
-0.0.19
View
85 tropo-provisioning.gemspec
@@ -1,70 +1,35 @@
-# Generated by jeweler
-# DO NOT EDIT THIS FILE DIRECTLY
-# Instead, edit Jeweler::Tasks in Rakefile, and run the gemspec command
# -*- encoding: utf-8 -*-
+$:.unshift File.join(File.dirname(__FILE__), 'lib')
+
+require 'tropo-provisioning/version'
+
Gem::Specification.new do |s|
- s.name = %q{tropo-provisioning}
- s.version = "0.0.21"
+ s.name = "tropo-provisioning"
+ s.version = TropoProvisioning::VERSION
- s.required_rubygems_version = Gem::Requirement.new(">= 0") if s.respond_to? :required_rubygems_version=
- s.authors = ["Jason Goecke"]
- s.date = %q{2010-07-28}
+ s.authors = ["Jason Goecke", "Juan de Bravo"]
+ s.email = ["jsgoecke@voxeo.com", "juandebravo@gmail.com"]
+
+ s.date = %q{2011-09-05}
s.description = %q{Library for interacting with the Tropo Provisioning API}
- s.email = %q{jsgoecke@voxeo.com}
- s.extra_rdoc_files = [
- "LICENSE",
- "README.rdoc"
- ]
- s.files = [
- ".gitignore",
- "LICENSE",
- "README.rdoc",
- "Rakefile",
- "VERSION",
- "lib/tropo-provisioning.rb",
- "lib/tropo-provisioning/tropo-provisioning.rb",
- "lib/tropo-provisioning/error.rb",
- "tropo-provisioning.gemspec"
- ]
- s.homepage = %q{http://github.com/tropo/tropo-provisioning}
- s.rdoc_options = ["--charset=UTF-8"]
- s.require_paths = ["lib"]
- s.rubygems_version = %q{1.3.7}
s.summary = %q{Library for interacting with the Tropo Provisioning API}
- s.test_files = [
- "spec/live-tropo-provisioning_spec.rb",
- "spec/spec_helper.rb",
- "spec/tropo-provisioning_spec.rb",
- "spec/live-tropo-provisioning_spec.rb",
- "examples/create_address.rb",
- "examples/create_user.rb",
- "examples/create_application.rb",
- "examples/delete_application.rb",
- "examples/list_addresses.rb",
- "examples/list_applications.rb",
- "examples/list_exchanges.rb",
- "examples/list_pin.rb",
- "examples/update_application.rb"
- ]
+
+ s.rubyforge_project = "tropo-provisioning"
+
+ s.files = `git ls-files`.split("\n")
+ s.test_files = `git ls-files -- {examples,test,spec,features}/*`.split("\n")
- if s.respond_to? :specification_version then
- current_version = Gem::Specification::CURRENT_SPECIFICATION_VERSION
- s.specification_version = 3
+ s.homepage = %q{http://github.com/tropo/tropo-provisioning}
+ s.require_paths = ["lib"]
- if Gem::Version.new(Gem::VERSION) >= Gem::Version.new('1.2.0') then
- s.add_development_dependency(%q<rspec>, [">= 1.2.9"])
- s.add_runtime_dependency(%q<hashie>, [">= 0.2.1"])
- s.add_runtime_dependency(%q<activesupport>)
- else
- s.add_dependency(%q<rspec>, [">= 1.2.9"])
- s.add_dependency(%q<hashie>, [">= 0.2.1"])
- s.add_dependency(%q<activesupport>)
- end
- else
- s.add_dependency(%q<rspec>, [">= 1.2.9"])
- s.add_dependency(%q<hashie>, [">= 0.2.1"])
- s.add_dependency(%q<activesupport>)
- end
+ s.add_development_dependency("rspec")
+ s.add_development_dependency("fakeweb")
+ s.add_development_dependency("yard")
+ s.add_development_dependency("rdoc")
+
+ s.add_runtime_dependency("hashie", ">= 0.2.1")
+ s.add_runtime_dependency("activesupport")
+ s.add_runtime_dependency("i18n")
end

0 comments on commit f10b4ab

Please sign in to comment.
Something went wrong with that request. Please try again.